[pacman-mirrors] 4.11.4 bugfix release

pacman-mirrors

#21

@servimo @tux

Thank you both for helping me nail this buggar.

Pushed package 4.11.3-2 to unstable.


#22

Thank you for your information
I did another test
Here is the Ouput for testing

So 22. Jul 18:38:40 CEST 2018

sudo pacman -U https://manjaro.moson.eu/pool/overlay/pacman-mirrors-4.11.3-2-any.pkg.tar.xz

$ sudo pacman-mirrors -f
	  2.934 United_States  : https://mirrors.ocf.berkeley.edu/manjaro/
   ..... South_Africa   : http://manjaro.mirror.ac.za/
   ..... South_Africa   : ftp://manjaro.mirror.ac.za/
	.: ERROR ftp error: URLError('ftp error: error_perm("550 Can\'t change directory to state: No such file or directory",)',) 'ftp://manjaro.mirror.ac.za/'
---------- skip
   0.191 Hungary        : http://quantum-mirror.hu/mirrors/pub/manjaro/
   ..... Germany        : https://mirror.philpot.de/manjaro/
.: ERROR [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841) 'https://mirror.philpot.de/manjaro/'
................. skip
Downgrade to pacman-mirrors Version 4.11.2-1

$ sudo pacman-mirrors -f

  0.120 Czech          : 02:10: https://mirror.dkm.cz/manjaro/
   ..... Germany        : 00:01: https://mirror.philpot.de/manjaro/
.: ERROR [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:841) 'https://mirror.philpot.de/manjaro/'

   0.177 Germany        : 00:13: https://mirror.netzspielplatz.de/manjaro/packages/

#23

For me “pacman-mirrors-4.11.3-2” is working


#24

I can confirm that I had the same 404 error bug on “pacman-mirrors-4.11.3-2”. Rolling back to “pacman-mirrors-4.11.2-2” fixed the issue.


#25

Did you refresh “pacman-mirrors” with the options (-f0 or -c all) after installing it?


#26

Strangely enough those commands didn’t fix it when I was running version 4.11.3 but it worked after I did the rollback to 4.11.2, ran the commands, and then installed it again.


#28

@starrynights89 @servimo

What confused me was the fact that depending on your choice of cli the mirror list was either correct or it missed the $repo/$arch part.

It was in fact the message outputted to the console which altered the server written to the mirrorlist but only when running when the default mirror pool was used.

If you was using a custom mirror pool the mirrorlist was correct. And since I did want to test against a specific German mirror - I used -c Germany which creates a custom mirror pool which uses one status message in the console.

When using the default mirror pool with -f (can also be used with custom mirror pool) or resetting the custom pool -c all which uses another status message - earlier mentioned codeline - which inadvertly altered the server url effectively creating invalid urls which in turn generate 404’s in pacman.

I am glad the code is in managable modules - so I did not have to go over thousands of code lines only the 55 lines function in a 150 line module responsible for writing the mirrorlist.

July 23, 2018 1:13 PM (Europe: Paris), July 23, 2018 4:13 AM (America: Los Angeles)
In first draw I failed to verify the mirrorlist created by interactive.

This mirrorlist has now been fixed too.


#29

4.11.4 gives me this,

[john@Dell13LapTop ~]$ sudo pacman -U https://manjaro.moson.eu/pool/overlay/pacman-mirrors-4.11.4-1-any.pkg.tar.xz
loading packages...
error: '/var/cache/pacman/pkg/pacman-mirrors-4.11.4-1-any.pkg.tar.xz': package missing required signature

4.11.3-2 loads fine. I’m on the testing branch.


#30
omg, I am on unstable, sorry


Ok, Pamac :wink:

Ok, pacui :smiley:


#31

Just got update available on pamac and it updated fine 4.11.4, on testing! Server sync issue probably.


#32

Just adding I’ve updated this (4.11.4) on a couple of systems and it seems to be running fine also.


#33

But you have the 4.11.4-1 installed

The error point you to your cache.


#34

This version is now on our stable branch with today’s update.


#35

I used pacman -U with a URL. When I changed the version to 4.11.3-2, the command worked. I’m guessing that I pinged that server before the signature had sync’d.

Fortunately, pamac handled the update for me so I now have 4.11.4-1.


closed #36