Pacman lists old Nvidia driver version

Nvidia new drivers(465) hasn’t listed in repository.

Tried:

❯ sudo pacman-mirrors -f && sudo pacman -Syyuu

Mhwd info:

❯ pacman -Ss nvidia                                                            
core/mhwd-nvidia 460.73.01-1 [installed]
    MHWD module-ids for nvidia 460.73.01
core/mhwd-nvidia-390xx 390.143-1 [installed]
    MHWD module-ids for nvidia 390.143
extra/egl-wayland 1.1.6-1
    EGLStream-based Wayland external platform
extra/ffnvcodec-headers 11.0.10.1-1
    FFmpeg version of headers required to interface with Nvidias codec APIs
extra/libvdpau 1.4-1 [installed]
    Nvidia VDPAU library
extra/libxnvctrl 465.27-1
    NVIDIA NV-CONTROL X extension
extra/linux414-nvidia 460.73.01-3 (linux414-extramodules)
    NVIDIA drivers for linux.
extra/linux414-nvidia-390xx 390.143-2 (linux414-extramodules)
    NVIDIA drivers for linux.
extra/linux414-nvidiabl 0.88-204 (linux414-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/linux419-nvidia 460.73.01-3 (linux419-extramodules)
    NVIDIA drivers for linux.
extra/linux419-nvidia-390xx 390.143-2 (linux419-extramodules)
    NVIDIA drivers for linux.
extra/linux419-nvidiabl 0.88-179 (linux419-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/linux44-nvidia 460.73.01-3 (linux44-extramodules)
    NVIDIA drivers for linux.
extra/linux44-nvidia-390xx 390.143-2 (linux44-extramodules)
    NVIDIA drivers for linux.
extra/linux44-nvidiabl 0.88-198 (linux44-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/linux49-nvidia 460.73.01-3 (linux49-extramodules)
    NVIDIA drivers for linux.
extra/linux49-nvidia-390xx 390.143-2 (linux49-extramodules)
    NVIDIA drivers for linux.
extra/linux49-nvidiabl 0.88-212 (linux49-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/linux510-nvidia 460.73.01-3 (linux510-extramodules) [installed]
    NVIDIA drivers for linux.
extra/linux510-nvidia-390xx 390.143-4 (linux510-extramodules)
    NVIDIA drivers for linux.
extra/linux511-nvidia 460.73.01-3 (linux511-extramodules)
    NVIDIA drivers for linux.
extra/linux511-nvidia-390xx 390.143-5 (linux511-extramodules)
    NVIDIA drivers for linux.
extra/linux512-nvidia 460.73.01-3 (linux512-extramodules) [installed]
    NVIDIA drivers for linux.
extra/linux512-nvidia-390xx 390.143-4 (linux512-extramodules)
    NVIDIA drivers for linux.
extra/linux54-nvidia 460.73.01-3 (linux54-extramodules)
    NVIDIA drivers for linux.
extra/linux54-nvidia-390xx 390.143-4 (linux54-extramodules)
    NVIDIA drivers for linux.
extra/linux54-nvidiabl 0.88-124 (linux54-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/nvidia-390xx-utils 390.143-1
    NVIDIA drivers utilities
extra/nvidia-dkms 460.73.01-1
    NVIDIA drivers - module sources
extra/nvidia-prime 1.0-4
    NVIDIA Prime Render Offload configuration and utilities
extra/nvidia-utils 460.73.01-1 [installed]
    NVIDIA drivers utilities
extra/opencl-nvidia 460.73.01-1
    OpenCL implemention for NVIDIA
extra/opencl-nvidia-390xx 390.143-1
    OpenCL implemention for NVIDIA
extra/xf86-video-nouveau 1.0.17-1 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards
community/bumblebee 3.2.1-22
    NVIDIA Optimus support for Linux through Primus/VirtualGL
community/conky-lua-nv 1.11.5-2
    An advanced system monitor for X based on torsmo with lua and nvidia enabled
community/cuda 11.3.0-1
    NVIDIA's GPU programming toolkit
community/cuda-tools 11.3.0-1
    NVIDIA's GPU programming toolkit (extra tools: nvvp, nsight, samples)
community/cudnn 8.2.0.53-1
    NVIDIA CUDA Deep Neural Network library
community/ffnvcodec-headers8.1 8.1.24.11-1
    FFmpeg version of headers required to interface with Nvidias codec APIs
community/gwe 0.15.3-1
    A system utility for controlling NVIDIA GPUs
community/linux-rt-lts-manjaro-nvidia-390xx 5.4-1 (linux-rt-lts-manjaro-extramodules)
    NVIDIA drivers for linux.
community/linux-rt-lts-manjaro-nvidiabl 5.4-1 (linux-rt-lts-manjaro-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
community/linux-rt-manjaro-nvidia 5.9-1 (linux-rt-manjaro-extramodules)
    NVIDIA drivers for linux.
community/linux54-rt-nvidia 460.73.01-1 (linux54-rt-extramodules)
    NVIDIA drivers for linux.
community/linux54-rt-nvidia-390xx 390.143-1 (linux54-rt-extramodules)
    NVIDIA drivers for linux.
community/linux54-rt-nvidiabl 0.88-37 (linux54-rt-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
community/linux59-rt-nvidia 460.73.01-1 (linux59-rt-extramodules)
    NVIDIA drivers for linux.
community/linux59-rt-nvidia-390xx 390.143-1 (linux59-rt-extramodules)
    NVIDIA drivers for linux.
community/mate-optimus 19.10.4-1
    NVIDIA Optimus GPU switcher
community/nccl 2.9.6-1
    Library for NVIDIA multi-GPU and multi-node collective communication
    primitives
community/nemo-run-with-nvidia-prime-run 0.1.0-1
    Nemo action to run a program with prime-run
community/nvidia-cg-toolkit 3.1-6
    NVIDIA Cg libraries
community/nvtop 1.1.0-2
    An htop like monitoring tool for NVIDIA GPUs
community/primus_vk 1.5-1
    Nvidia Vulkan offloading for Bumblebee
community/pycuda-headers 2020.1-6
    Python wrapper for Nvidia CUDA
community/python-pycuda 2020.1-6
    Python wrapper for Nvidia CUDA
multilib/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
multilib/lib32-nvidia-390xx-utils 390.143-1
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-cg-toolkit 3.1-7
    NVIDIA Cg libraries
multilib/lib32-nvidia-utils 460.73.01-1 [installed]
    NVIDIA drivers utilities (32-bit)
multilib/lib32-opencl-nvidia 460.73.01-1
    OpenCL implemention for NVIDIA (32-bit)
multilib/lib32-opencl-nvidia-390xx 390.143-1
    OpenCL implemention for NVIDIA (32-bit)
multilib/lib32-primus_vk 1.5-1
    Nvidia Vulkan offloading for Bumblebee

System info:

❯ inxi -Fxza
System:    Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 root=UUID=bb6f469f-297c-47b1-87b2-6769924b4928 rw quiet apparmor=1 
           security=apparmor resume=UUID=73db2f15-96f1-433f-9b8f-e1f6baabd295 udev.log_priority=3 
           Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 3801 
           date: 04/07/2021 
Battery:   Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3 serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: 0 microcode: 8701021 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 94830 
           Speed: 3950 MHz min/max: 2200/3950 MHz boost: enabled Core speeds (MHz): 1: 3950 2: 3950 3: 3948 4: 3955 5: 3949 
           6: 3949 7: 3933 8: 3949 9: 3950 10: 3949 11: 3944 12: 3954 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] driver: nvidia v: 460.73.01 alternate: nouveau,nvidia_drm 
           bus-ID: 09:00.0 chip-ID: 10de:2182 class-ID: 0300 
           Display: x11 server: X.org 1.20.11 compositor: gnome-shell driver: loaded: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 direct render: Yes 
Audio:     Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:1aeb 
           class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.26 running: no 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280 
           IF: wlp4s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI 
           modules: r8169 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter> 
           IF-ID-2: veth7ae4c7b state: up speed: 10000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-6:3 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 689.33 GiB used: 141.29 GiB (20.5%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 2B2QEXM7 scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G size: 223.57 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 80RL scheme: GPT 
Partition: ID-1: / raw-size: 206.1 GiB size: 201.86 GiB (97.95%) used: 141.29 GiB (70.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 maj-min: 8:3 
Sensors:   System Temperatures: cpu: 54.2 C mobo: 0 C gpu: nvidia temp: 38 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 29% 
Info:      Processes: 304 Uptime: 29m wakeups: 6 Memory: 15.61 GiB used: 2.81 GiB (18.0%) Init: systemd v: 247 tool: systemctl 
           Compilers: gcc: 10.2.0 Packages: pacman: 1493 lib: 405 flatpak: 0 Shell: Zsh v: 5.8 running-in: tilix inxi: 3.3.04 

How do I install Nvidia driver v465?

you have to go in Testing to get version 465.27

Ok i got it. Thanks.

I used another approach, because switching to testing ruined my workflow.

I’ve cherry pick packages from testing repo, here is how:

sudo pacman -U https://manjaro.lucassymons.net/testing/core/x86_64/linux512-5.12.8-1-x86_64.pkg.tar.zst https://manjaro.lucassymons.net/testing/extra/x86_64/linux512-nvidia-465.31-6-x86_64.pkg.tar.zst https://manjaro.lucassymons.net/testing/extra/x86_64/nvidia-utils-465.31-1-x86_64.pkg.tar.zst

By the way, is this way allowable? I’m quite new to manjaro repo.