Pacman doesn't see the latest version of the package

Happy New Year everyone!

I started reading on ZigLang recently and wanted to install it. I found online that the latest version is 0.9 and when I check Arch Linux - Package Search it really says the version is 0.9.0-1 in community repo and that it was last updated on 2021-12-21 which is 12 days ago now. When I try pacman -S zig it says: Packages (2) lld-13.0.0-1 zig-0.8.1-2. Why does it see old 0.8 version and not new 0.9? I also tried running pacman-mirrors -f5 && pacman -Syyu but I still get 0.8 version when I try to install it.

check package versions here :point_down:

its on 0.8 on stable branch. you can switch to testing branch to use 0.9


You are in Manjaro, not in Arch. Manjaro has it’s own repos. You can see in the link that ishaanbhimwal has sent, that Manjaro’s package versions don’t need to be in sync with Arch.

1 Like

:man_facepalming: of course, silly me. Thank you guys!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.