Packages for non-free firmware blobs for USB Wifi dongle?

Hi All,

I have an old IPX system with no expansion slots that I want to give Wifi and an also somewhat older USB Wifi dongle SpeedTouch 120g.

On the internet I found instructions for Ubuntu to install a package named “linux-firmware-nonfree”, but pacman doesn’t find that.

The adapter uses an Intersil prism chipset and would aparently need a firmware file named “isl3886usb”

What package do I need on manjaro to get the proprietary firmware blob for this adapter installed (or any other for that matter)?

How do I find this info myself next time? Searched the forum and wiki to no avail …

Thanks in advance!

P.S. found this firmware file:

How do I install it on manjaro?

Hey Leny,

By enabling and using the AUR from the software manager Pamac.

Okay, thanks - I’ll try that.

The system at hand is off line and I’m mostly using command line, but I’ll try installing it on another system using pamac and copy the packages from /var/cache/pacman/pkg or some such.

Check out the man page for pamac, there are options to build from local directories. Depending on the kind of package you might need the base-devel meta package installed on the target machine to make this work.

Excellent - thanks for the pointer Hanzel! Will try and get back here (later) …

Thanks again!

Okay - solved - kinda :slight_smile: Adapter is now up and running but doesn’t see the access point, will probably need a range extender or something similar.


  • Found a driver for isl3886usb on AUR
  • installed it using pamac (as suggested by Hanzel) on a different machine with internet access .
  • copied the isl3886usb-firmware-someversionnumber-any.pkg.tar.zst from /var/cache/pacman/pkg/ to the other machine (via thumbdrive)
  • plugged in the USB wifi adapter

It probably just worked from that point on, but no connections were offered due to the accespoint being out of range … at least that is what I conclude from this for now:

$ hwinfo --netcard --wlan --bluetooth | grep -Ei “model:|driver:|status:|cmd:|file:|detected:” | grep -v “Config Status”
Model: “Qualcomm Atheros AR8152 v2.0 Fast Ethernet”
Driver: “atl1c”
Device File: enp7s0
Link detected: no
Driver Status: atl1c is active
Driver Activation Cmd: “modprobe atl1c”

Thanks for the pointers Hanzel!

Scratch that … sorry … that’s not the USB device … better get some sleep first and try again what’s up tomorrow :upside_down_face:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.