Package request: manjaro-zsh-config, fonts-noto-sans-mono maybe too

I’m trying to achieve the same look & feel of the zsh prompt as in the standard desktop (not ARM) Manjaro KDE version. But the manjaro-zsh-config package is not available for ARM not in the standard repositories, nor in the AUR.

I manually transferred all the files from manjaro-zsh-config and nerd-fonts-noto-sans-mono packages installed in desktop Manjaro KDE to my Manjaro ARM running the KDE/Plasma, but the result is still not the same as in desktop version. Something is still missing.

Would it be possible to make the manjaro-zsh-config and maybe also the nerd-fonts-noto-sans-mono packages available in the ARM repositories?

Thx for considering.

I can confirm that the package from the AUR is also installable on ARM devices.
(tested on my Pinephone)

Link and installation command

AUR (en) - nerd-fonts-noto-sans-mono
pamac build nerd-fonts-noto-sans-mono


We don’t have any immediate plans to work on or switch to ZSH, so we will not be including manjaro-zsh-config until we have a need for it.

You can easily build it yourself in a few easy steps

sudo pacman -Syu base-devel git
git clone
cd manjaro-zsh-config
makepkg -si

Note: you may need to resolve dependencies manually - check the depends array in the PKGBUILD script. If they are not inherited from Archlinux Arm then you can build them from AUR.

1 Like

Thank you all for all the important information and guidance on how to make it working the other way.

Sorry for the noob question, but is there any other way how to make the manjaro-zsh-config after cloning it from git? I’m running Manjaro ARM in chroot, therefore makepkg does not work to me, because system was not started with systemd. And the README lacks any info on how to make it.

Then you have other issues - makepkg works fine in chroot.

We can open a new branch and add ARM Support and merge it later to master when we ready for it.

Hmm that’s strange. I run the makepkg -si once more and this time it went without any complaints on not running with systemd and installed the package.

OK, that makes it solved for me. The zsh prompt still does not look like exactly as on the standard Manjaro KDE, but I believe it needs just some fine tuning now.

Thank you for helping.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.