Package Manager Will Not Update. Again

Package manager wont even update via terminal.

Via the package manager I get

# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
# Contributor: Sergej Pupykin <>
# Contributor: Charles Mauch <>
# Generator  : CPANPLUS::Dist::Arch 1.32

pkgdesc="Get stock and mutual fund quotes from various exchanges"
license=('PerlArtistic' 'GPL')
depends=('perl-date-manip>=0' 'perl-date-range>=0' 'perl-date-simple>=0' 'perl-datetime>=0' 'perl-datetime-format-iso8601>=0' 'perl-datetime-format-strptime>=0' 'perl-html-parser>=0' 'perl-html-tableextract>=0' 'perl-html-tokeparser-simple>=0' 'perl-html-tree>=0' 'perl-html-treebuilder-xpath>=0' 'perl-http-cookiejar>=0' 'perl-http-cookies>=0' 'perl-http-message>=0' 'perl-io-string>=0' 'perl-json>=0' 'perl-json-parse' 'perl-lwp-protocol-https>=0' 'perl-mozilla-ca>=0' 'perl-readonly>=0' 'perl-spreadsheet-xlsx>=0' 'perl-string-util>=0' 'perl-text-template>=0' 'perl-try-tiny>=0' 'perl-web-scraper>=0' 'perl-xml-libxml>=0' 'perl-libwww>=0' 'perl>=5.10.1')
checkdepends=('perl-test-kwalitee>=0' 'perl-test-perl-critic>=0' 'perl-test-pod>=0' 'perl-test-pod-coverage>=1.00')

build() {
  ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
      PERL_AUTOINSTALL=--skipdeps                            \
      PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'"     \
      PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \

    cd "$srcdir/$_distdir"
    /usr/bin/perl Makefile.PL

check() {
  cd "$srcdir/$_distdir"
    make test

package() {
  cd "$srcdir/$_distdir"
  make install
  find "$pkgdir" -name .packlist -o -name perllocal.pod -delete

# Local Variables:
# mode: shell-script
# sh-basic-offset: 2
# End:
# vim:set ts=2 sw=2 et:



Is anyone else having issues?

The first one looks like an AUR package (specifically the PKGBUILD… which you need to accept or exit usually).

Also, as the Arch User Repository … it is technically unsupported. But you can see more about it all here: Arch User Repository - Manjaro

The second one is an over-1-month-old change that was adopted from Arch and mentioned in the update announcements.

PS. I fixed the title and categories because spelling and this has nothing to do with plasma.


pamac. You mean pamac. Use the words. pacman couldnt possibly have your first problem.
(because it does not interact directly with the AUR - something you have obviously enabled in the pamac GUI, but do not fully understand)


… the point was to get you to name the applications you were using.

You still failed to do so.

But you did manage to locate the caps lock, for whatever thats worth.

Here, do this.

sudo pacman -Syuu jre-openjdk

If it doesnt work, be a doll and share the errors received. ok ty :kissing_heart:

1 Like

Hi @Iwanttolinux,

it can always be that some package conflicts combined with AUR packages may have issues. It seems you use the graphical package manager Pamac. It also works in a terminal by typing pamac upgrade. You can post that output and errors you may have to this thread.

As already mentioned, there are some changes made to JAVA JDK and how they are now maintained. Seems you have at least the Java runtime installed on your system.

To quote the article:

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su (as root user) and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

Based on your error message you have both JRE and JRE-headless. So you will need to choose one of them and install it manually since they would conflict each other now:

As suggested by @cscs you can do that with sudo pacman -Syuu jre-openjdk.
Or install jre-openjdk before you update the other packages. This you can also do with pamac:

pamac install jre-openjdk
pamac upgrade

If you want jdk-openjdk instead it would be sudo pacman -Syuu jre-openjdk or

pamac install jdk-openjdk
pamac upgrade

Using the big tools


pacman -Qqem > ~/cust-pkglist.txt
sudo pacman --no-confirm -Rdd $(pacman -Qsq jre-) $(pacman -Qsq jdk-) $(pacman -Qqem)
sudo pacman -Syu jre-openjdk
pamac build --no-confirm $(cat ~/cust-pkglist.txt)

what this will do is

  1. save a list of custom packages
  2. unconditionally remove any packages starting with jre- or jdk- and all custom packages
  3. fully sync your system - adding in jre-openjdk package
  4. unconditionally rebuild custom packages using the saved list as input


  • man pacman
  • pamac build --help
1 Like