Package Manager seems to be stalled

Just installed a fresh KDE Plasma and add/remove listed 2+ gigs of updates, so I just clicked the accept - the packages all downloaded, and the listing stopped… and then nothign else has happened, nearly two hours now.

So I tried a reboot and shutdown, and all I get upon restart from either is “Waiting for another package manager to quit” it just seems to be doing nothing at all, no disk activity light, nothing. and the lsof does not seem to run in this latest KDE? I did see that in another thread, but konsole doesn’t allow the code.

Seems like you still have the lock files - delete them and run the update again.

1 Like

umm, re that “paste in” you made above, I waited 2 hours before resorting to a restart!! Wasn’t like I waited a few seconds! Plus, there was nothing about kernels in it at all!

And that link just goes back to the main OS ISO download page??

And what are lock files?

Boot from usb. Then

sudo su -
manjaro-chroot -a
rm -f /var/lib/pacman/db.lck
pacman-mirrors -f
pacman -Syyu

Here is another similar topic

Telling you to remove /var/lib/pacman/db.lck

1 Like

I had to resort to re-downloading the ISO, installing that and then doing a “step by step” update of things…first ting I did was to update the kernel (as recommended by the system) and then do the graphics via the Settings Manager auto install, before I did anything else. That seemed to have been one of the main culprits. On a previous box it was AMD graphics and it had no issues at all, full auto update ran smoothly and in a timely fashion… but this new box is intel/nVidia - not sure if that was 100% the issue, but it all works now. Another thing I found was that selecting non-free drivers at the install stage also froze the install, and nothing worked form the get-go. Had to chose free, and then do the manual install (via manager as noted above).

There is every reason to be diligent when syncing the system to the main repo.

Custom packages


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.