Package Manager Corrupted?!

Not sure how it happened or when, but I’m unable to add or remove software through pacman or package manager. For instance, when I go to package manager and remove “MS Teams”, it says target not found. If I try to install anything, “inkscape” for instance, I get conflicting dependencies:

  • zfs-dkms and linux54-zfs are in conflict.

When I run pacman -Syu, i get …
acman -Syu

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
warning: libldac: local ( is newer than extra (
:: Replace mhwd-nvidia-418xx with core/mhwd-nvidia? [Y/n] y
:: Replace mhwd-nvidia-430xx with core/mhwd-nvidia? [Y/n] y
:: Replace mhwd-nvidia-435xx with core/mhwd-nvidia? [Y/n] y
:: Replace mhwd-nvidia-440xx with core/mhwd-nvidia? [Y/n] y
:: Replace mhwd-nvidia-450xx with core/mhwd-nvidia? [Y/n] y
:: Replace mhwd-nvidia-455xx with core/mhwd-nvidia? [Y/n] y
:: Replace opencl-nvidia-440xx with extra/opencl-nvidia? [Y/n] y
:: Replace pamac-tray-appindicator with extra/pamac-tray-icon-plasma? [Y/n] y
:: Replace pygobject-devel with extra/python-gobject? [Y/n] y
:: Replace user-manager with extra/plasma-desktop? [Y/n] y
:: Replace xorg-luit with extra/luit? [Y/n] y
:: Replace xorg-server-xwayland with extra/xorg-xwayland? [Y/n] y
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: zfs-dkms and linux54-zfs are in conflict


Operating System: Manjaro Linux
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Kernel Version: 5.4.72-1-MANJARO
OS Type: 64-bit
Processors: 48 × AMD Ryzen Threadripper 3960X 24-Core Processor
Memory: 125.8 GiB of RAM
Graphics Processor: Radeon RX 5500 XT

You need to delete one of those packages.

1 Like

This kind of error has been seen before with solution:


May have spoken too soon. After an update and reboot, system is lagging heavily.

This was part of the solution and put me on the path to figuring out how to resolve, though I still don’t know what happened or how, the system is running correctly again. I worked my way through a host of errors until I was finally able to run a pacman -Syu.