Package installation and removal

A few basic questions from someone fairly new to Linux. Comments requested.

Take for example the application Standard Notes.

If I install with pamac, the aur installs a version that works except that it has a bug (highlighting text does not give a different colour for the selection so I cannot tell what is highlighted). A version installed from flatpack works and the bug is not present.

If I leave the flatpack version and tell pamac to uninstall the aur version, it removes the program, but the link to it remains in the launcher (linux equivalent to windows start menu) and I cannot remove it from the launcher. How do I do this?

I have been told not to use flatpack if aur has a version, but the aur version has the bug.

Another example. The aur version of ProtonVPN was working, but now does not launch after something unidentified (by me) updated. The flatpack version works. Why?

Some programs say to download from github or offer different packages, but they assume I know how to install what is downloaded. Is there a command to tell terminal to install a downloaded package?

Some programs sometimes do not install because the target cannot be found. Sometimes pacman -Syu works. But not quite always.

Basic questions probably, but so far, is over my head. I would like to learn.

Apps on Flathub come in most cases directly from the developer and flatpak ships its own libraries and don’t use system ones. Therefore, you can expect that it works as the developer intended and tested.

AUR on the other hand is managed by users for users.

Flatpak also creates a desktop file. Therefore, can you verfiy if the desktop file is the one from the AUR?

That depends on your preference. For a Normie I would advice to use flatpak nowadays, since it is mostly supported by the developers (you can see that on the flathub website). For example.: Proton VPN | Flathub, you see there by Proton AG.

Probably the AUR package have to be rebuilt. Just reinstall it.

Depends on what “package”. There is no egg-laying wool-milk-sow ( german: Eierlegende Wollmilchsau) :wink:

Database is not in sync. Therefore problmes happens. Pacman and pamac have different places for their databases.

1 Like

sudo pacman-mirrors -f 5
sudo pacman -Syyu

Should fix the normal updates (then rebuild aur)

1 Like

Thank you for the comments and advice to use flatpack!

I do not have a desktop file for Standard Notes. I used what I am calling the launcher to add to the panel and launch the program from there. I verified that it is the flatpack version.

I have both versions of Standard notes in the launcher.

I also have two of the Proton VPN in the launcher, but the AUR version does not launch.

Reinstalling the AUR ProtonVPN gives the same error, rebuilding did not solve the problem.

[steve@steve ~]$ Sudo pacman-mirrors -f 5
bash: Sudo: command not found

If your aur proton is initially installed before may, then it was probably with python 3.10. Proton is heavily python dependent, once a year there is major update and all such packages need fixing. Please lead any of the announcements - it links to turorial.

.desktop are all shortcut files in linux. Even the items in the start menu. If you use XFCE, there is the “menu editor” to well, edit the menu.

1 Like

Uhm, i’m writhing on a phone wich autocorrects… Linux makes difference between small case and upper case. Of course it is


Smallcase. Almost always the commands are smallcase, with the important exception of pacman -S which is really a big S

1 Like

This worked.

[steve@steve ~]$ sudo pacman-mirrors -f 5
[sudo] password for steve:
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool:
::INFO => Mirror status:
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
0.219 Canada : Xenyth Cloud Public Mirror
::INFO Writing mirror list
::Canada :$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
[steve@steve ~]$ sudo pacman -Syyu
:: Synchronizing package databases…
core 147.8 KiB 985 KiB/s 00:00 [######################] 100%
extra 8.7 MiB 10.8 MiB/s 00:01 [######################] 100%
community 29.0 B 1450 B/s 00:00 [######################] 100%
multilib 146.5 KiB 6.22 MiB/s 00:00 [######################] 100%
:: Starting full system upgrade…
warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
warning: perl-finance-quote: local (1.5400-1) is newer than extra (1.55-1)
there is nothing to do

I then refreshed the databases in pamac and it finished successfully.

I didn’t know about menu editor - thank you. It reports some parsing errors, so I guess I should deleted the items it references?

I am on XFCE. I tried to delete the entry under office for Standard Notes in the menu editor but the circled x at the top would not delete it, neither would the minus sign at the bottom.

Flatpak is much less likely to cause problems for someone new to Linux.

Use of the AUR assumes that you know what you’re doing and are aware of the potential risks and problems.

1 Like

Users are also more likely to run into certain problems due to flatpaks isolation.
(there are numerous posts about users who cannot access files from a flatpak application, etc)

Or problems that can only be fixed by the flatpak maintainer and not be system updates or distro devs patching … you must just rely on whatever the flatpak provides, which can leave you in an unsupported state.
(some flatpak maintainers dont follow the guidelines properly and assume libraries from Ubuntu exist, etc)

Flatpaks can and have been provided with malware as well.

The warning about the AUR is pertinent … but it also applies to all third party software.

1 Like

In other words, find a version that works, no real generic problem free version.

You know all that applies to any way you install app.

1 Like

Not exactly.

But sorta, mostly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.