Overview / Activities mode doesn't work after Blank Screen, User Switch and Suspend

As the title says, the Overview / Activities mode shows nothing (neither opened windows, nor applications, nor workspace list) and acts weird after the Blank Screen, User Switch and Suspend.
Both “Show Applications” button and “Super” key ways to enter the Overview / Activities mode have this issue.
When I press “Show Applications” button, the apps shortcuts are invisible but clickable to run them.
Futhermore, I cannot exit this “broken” Overview / Activities mode.
The only Alt+F2 - “r” command helps to recover it.
Everything what happends is showed in the gif screencast on my google drive (delete the first “_” char in the link):

In order to check if this problem covers all the gnome-shell or only my user session, I’ve created a new guest user and in this guest user session everything is okay.
So the problem covers only my user session.


No one answered, so I’ve decided to look for the causes myself.
First, I figured out that in general the cause lied somewhere in dconf settings (~/.config/dconf).
There are a lots of them, so it was difficult and time-consuming to search a specific setting in the dconf editor.
On the next step I tried to switch off gnome extensions one by one.
And - here it is!
Switching off the “Quick Close in Overview” extension (gnome-shell-extension-middleclickclose) solved the problem! (logging off and logging in again is needed)
What is interesting - subsequent switching this extension on doesn’t cause the problem again!
So, everything works fine at the moment and I hope this will last long)))

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.