[OUTDATED] How to run Hearthstone with playonlinux

games
wine
tutorial
playonlinux
gaming

#1

THIS GUIDE IS OUTDATED!!!

  1. Make sure those packages are installed (probably you don’t need all of them, but just to be sure)

lib32-alsa-lib #for pulseaudio users also: lib32-alsa-plugins and lib32-libpulse
lib32-libldap
lib32-lcms2
lib32-gnutls
lib32-libpng12

  1. Don’t install League of Legends directly from the playonlinux list because most likely it won’t work. If you have already installed it and it doesn’t work then go to “Playonlinux-> Configure” and remove the virtual drive that has been created. Copy the modified script from http://pastebin.com/bkAkWdXj (make sure you copy all total 80 lines) and save it to a file named something like:

hearthstone.sh

  1. Open Playonlinux, click “Tools-> Run a local script” and select the script you created. Follow the instructions and install the game.

CREDITS:
The script is based on the original script which you can find here https://www.playonlinux.com/en/app-1950-Hearthstone.html with the only difference being:
The line:

POL_Wine_PrefixCreate “1.9.18”

is changed to:

POL_Wine_PrefixCreate “2.0-staging”


How can I edit old topic?
How to install Hearthstone on Manjaro?
How can I edit old topic?
#2

I did just what you said and I got an error after the “Starting Battle.net” window. The bar starts loading and then it shows a message like “Downloading…” very quickly before it crashes.
After that, playonlinux says it is restarting and then prompts the following error: “Error in POL_Shortcut” “Binary not found: Battle.net Launcher.exe”. I believe the setup window crashed before the installation process or the downloading was complete.

Following the script, I can see that the installation fails at the line
POL_Shortcut “Battle.net Launcher.exe” “$TITLE” “$TITLE.png” “”

What can I do?


#3

I use to be able to play Hearthstone in Manjaro. Though it’s been a while. I think I read somewhere that you need to install “ttf-ms-fonts” from AUR. I might be wrong though.


#4

On the playonlinux install script, it says that Microsoft Fonts are not installed and then it starts downloading (and installing) them. But I decided to install “ttf-ms-fonts” from AUR just in case. But it did not work :c

But thanks for the advice.

EDIT:
Also, after the installation from the AUR, the playonlinux script still prompted a message saying that the fonts were not installed and began to download them.


#5

When it asked you for language what did you choose? I had problems with heroes of the storm because the English (EU) link was broken. So, maybe there is a similar problem here. Try to choose a different one like English (US). You can change language afterwards from battlenet.


#6

I’ll try this later but I think this is not the problem. I tried a bunch of different things to install hearthstone. In one of them I used wget on the script’s link. It downloaded fine.
Also, the installer window does appear. If the link was broken, I think it would not even download.
Maybe the installer from the link is, somehow, corrupted.

I was using Manjaro-Gnome. Now I’m going to install Manjaro-XFCE and see if I can install it there. The reason I’m doing this is because I discovered that the catalyst driver from AMD has a certain incompatibility/bug using the new version of Gnome. So I’m going to try this new path. Even though I do not think that this is the problem, maybe it’ll work.

EDIT:
Just so you know, it didn’t work. :confused:
Even with XFCE fresh installed and using the catalyst drivers. This is pretty sad.
If you have an idea of what I could do, please tell me.
Thanks for the help, anyways.


#7

I added some libraries dependencies at my guide for league of legends at step 3 here: [OUTDATED] How to run League of Legends with playonlinux. Try to install them, maybe they are needed for hearthstone too.

If this didn’t work try to delete the virtualdrive and add the lines:

POL_Wine_OverrideDLL “native,builtin” "msvcp100"
POL_Wine_OverrideDLL “native,builtin” “msvcr100”

before the line

POL_Wine_OverrideDLL “native,builtin” “msvcp140”

Then run the script again.

What GPU do you have? I have an AMD radeon HD 7750 and I’m using the opensource radeon drivers.


#8

It worked!
I only had to install those libraries on the LoL link ([OUTDATED] How to run League of Legends with playonlinux), nothing else.
Thanks for all the help!

OBS.: The game runs just fine, but there is something wrong with the sound played when a friend sends you a message. For some reason, it plays a very loud noise that has nothing to do with the game. It happens everytime a message is received inside Hearthstone. Is there a way to disable this sound or to fix it?


#9

Nice! I added these libraries to the guide.

I don’t play much, so I’ve never experienced the issue you are describing. I did a google search, but I didn’t find anything. :disappointed: If I think of anything useful I will let you know.


#10

Thanks for all the help! :smile:
Maybe I’ll figure out the sound issue later. If I do, I’ll post it here


#11

EDIT: Updated wine version at 1.9.22-staging


#12

I have Hearthstone on Linux for about 2 years. I installed it on Manjaro KDE as soon as it became my main OS.
I had to install the microsoft fonts with winetricks. No idea why the package from AUR did not work. Also lib32-libldap. Then the installation worked just fine.
I play on wine 20 rc5 (system) and works great with NVidia drivers. Is it better with 1.9.22? Because there was a patch for Hearthstone on wine 20 Rc4.
Also a big bravo for plasma as alt-tab works with no need for virtual desktop, and with OBS recording.
Happy to report ranked 18 (for now).


#13

Better use the latest wine. I will update the guide to use wine 2.0-rc5. I need to reach trust level 3 first on the forum, because right now I cannot edit it.


#14

UPDATE: I upgraded wine version to 2.0-staging.


#15

Any suggestions on how to run it right now? I tried all of mentioned wine versions, and it does not work for my on any. I am able to run battle.net launcher, after I run hearthstone it show me splash screen, and after ~10 seconds it disappears. No errors, no crash warnings, it just disappears.


#16

There must be some errors/warnings in the terminal output?


#17

Well, it turns out that it work now. I typed in prefix’es console “winetricks forcemono”.
I use 2.10 staging.


#18

Yeah, this was a recent edition to get Hearthstone to work in Wine.


#19

THIS GUIDE IS OUTDATED!

Sorry i have forgotten to close this topic. I no longer play hearthstone so I’m not really in position to follow if the game works or not. So this guide is OUTDATED. You can probably find better guides-tutorials on youtube and the internet, or maybe create a more up-to-date guide here in the manjaro forum (I believe that there is a new Blizzard app to run these games nowadays but I haven’t checked it out).