Os-prober is detecting 2 windows partitions

Is there a way to stop os-prober from detecting extra windows partition?

I had just 1 windows partition in grub menu, now I have 2, after recovering the thing from booting error

I need to make os-prober stop detecting the extra partition. Is there a way to do that, permanently? (So it won’t appear again after every grub update)

and do you have actually 2 windows installations?

No, only one

The other entry in grub is pretty redundant

open grub file located in /boot/grub/grub.cfg
then search for menuentry, and remove the ones you want
update grub: sudo update-grub
reboot and dont mess it up

I did those, and grub update still adds the extra partition into its list

Is there something else that I need to remove to keep it from being detected?

well you probably didnt do it right … after modifying the file and running update grub, did the os prober detected the windows you removed?

Yea, I removed the entry in grub.cfg, did grub update, rebooted, and still seeing the thing.

I tried removing the entry without doing grub update, it worked, but it’s just a temporary solution.

Please, show the output of sudo update-grub

do you use efi? whats the output from:
sudo efibootmgr -v

Generating grub configuration file …
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows 8 on /dev/sda1
Found Windows 8 on /dev/sda2
Found memtest86+ image: /boot/memtest86+/memtest.bin

I’m not using efi, just legacy

Clearly we see where the two entries came from. What do you have in /dev/sda1 and /dev/sda2?

sda1 is the reserved partition
sda2 is the one with full installation stuff

I want to keep sda2 from being detected

Something must be happened when I fixed the booting error.

Yes, it seems to be the case. I’m not sure what triggers os-prober to detect a partition as Windows or not. I have to read a little bit to clarify that. I will come back later to you with some answer

In the meantime, do both entries work? How did you fix the booting error, with Windows utilities?

Both entries work, it feels super redundant :joy:

I used bootrec stuff from recovery mode, no 3rd party utility

so if both work, does it mean you have 2 windows boot partitions?


if you have 2 boot windows partitions, then deleting one should fix it?
whats the output from, and use formatting, click this icon in editor: </>
sudo parted -l && lsblk