Origin not launching within Steam

Hello, these days I decided to buy FIFA 22 on steam because it was at a good price, then I installed it and tried to play it. At first a tab was opened that asked me to log in to origin, then it began to install origin. But when it was near the middle, it closed. I tried to open the game again and the following poster came up repeatedly. The game is with proton 6.3.8. I would appreciate any possible help


According to ProtonDB it works.

Delete the prefix (for FIFA 22 it should be ~/.local/share/Steam/steamapps/compatdata/1506830) and try again to do the first time setup and all.

Origin is problematic under Proton though, but the game should work once it is installed in Origin.

1 Like

Should I delete the 1506830 folder?

What do you think :slight_smile:

1 Like

If you say it works, I will do it friend

in that direction I can’t find that folder, in fact there is no trace of origin in them either. In the following address if I found a folder called Origin with many files including Origin.exe


I don’t know what this folder is for (it is not even a valid AppID I can’t find what this folder is supposed to be for), but I can see you removed Steam and installed a Snap or Flatpak version of it… why did you do that? Any particular reason to not use Steam normally?

The game prefix folder should be where I told you if you use Steam the normal way. Deleting it should make it so Steam do the first time initialization for the game and creates everything for the game to work.

If you use Snaps or Flatpak that is another layer of issue on top of that I don’t want to deal with.

1 Like

I use steam flatpak because steam manjaro I never run csgo, install it several times and yet the screen goes black and crashes. I have not tried with other games since they take a long time to install on my internet (I live in Argentina) and I don’t know if it also happens with other games. But with CSGO I have problems that with steam flatpak not. If you know how I can solve this problem or if a configuration is needed, please tell me, maybe it will solve all the problems for me.

Hi, this game runs fine with steam-manjaro. I use the steam beta and Proton experimental, but it requires a custom fifasetup.ini for AMD-GPU’s to work around some problems with DX12, as it has a 30 FPS lock for AMD on DX11. In theory it should also run with the flatpak version, everything else has already been pointed out.

What is the output of:
find ~/.var -name "1506830"

1 Like

is that I have integrated Intel graphics, I have an i7 10700. How can I do then?
switch to steam manjaro and this is the output to the command


I would like to share with you the screen recording that I made when I try to start CSGO, since I always had that problem with steam manjaro. And it shouldn’t have.

For CS GO take a look at this existing bug report and try the mentioned workarounds.

The output shows that fifa is not installed in .var, please also provide the output of:
find ~/.local -name "1506830"

1 Like

Thanks friend, now I will try some of those solutions. This is the output of that command:


Seems there is only the shader cache but no wine prefix, where it should be…
Alright so what does:
find ~/ -name "FIFA 22"
find ~/ -name "1506830"

Or do you use a custom location for steam games?

I used a second hard drive for steam games. But all games are in SteamLibrary folder in /home/HDD

So where is FIFA installed?
If the game is installed on a different drive, you need to look there for the wine prefix.
Also isn’t this normally sandboxed and you should only have r/w access to .var by default? Or did you add the permission to use a different folder outside .var?

1 Like

FIFA is in /home/HDD/SteamLibrary/steamapps/1506830 the second hard drive is mounted in / home / HDD. In this directory I have all my steam games. What must i do?

If it is installed in another location than the default, then the prefix will be in the upper folders of the game installation path, check /home/HDD/SteamLibrary/compatdata to locate the prefix folder.

Also with integrated graphics, running games through Proton, especially demanding games, is most likely not possible, it could work but Proton games need power.

The minimum for this game is a GTX 660, here is your graphic chip compared to a GTX 660 regarding performance.

//EDIT: I know it is easier to try to get every issue you have fixed in one thread, but if you continue having other issues with other game than FIFA 22, then open a new thread for the specific issue.

I have seen in proton db that they run fifa 22 with integrated gpu too, that’s why I try, anyway I have played dirt rally 2.0 with this gpu, and the hunter through proton 6.3.8

OK but what about the rest, the important stuff to fix the issue with Origin not installing? Can you check and try?

if you mean the features, my pc has better condition than most of the ones I saw. I have an i7 10700 with 16gb RAM and kernel 5.15.12-1