optimus-prime Nvidia driver won't load

nvidia
optimus
#1

Hi there,
since my last post about setting up my graphic card setup, I've read some articles and tried the optimus-manager again. But It still doesn't work so I've decided to begin a new thread with a more concrete discripiton of my problem.

So after letting mhwd install the nonfree drivers, I've backed up and removed (as in the wiki article recommended all configs in /etc/X11/xorg.conf,/etc/X11/xorg.conf.d/ and also in /etc/X11/mhwd.d/). After that I've stopped and disabled the bumblebeed service and enabled the optimus-manager.service. Then I've used the command optimus-manager --switch nvidia to switch from the intel GPU to the Nvidia GPU as expected, the display manager got restarted and I logged back in. After running glxinfo | grep OpenGL and got this

response
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.0.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:```

that the Intel driver is still loaded instead of the Nvidia driver. A quick look inside journalctl -o optimus-manager

showed
May 05 00:54:31 GrinzoldDspalter python[714]: Received command : nvidia
May 05 00:54:31 GrinzoldDspalter python[714]: Writing requested mode
May 05 00:54:31 GrinzoldDspalter python[714]: Restarting login manager

So there is no error from optimus-manager in this log.

A look in systemctl status optimus-manager
gave the

output
● optimus-manager.service - Optimus Manager Commands Daemon
   Loaded: loaded (/usr/lib/systemd/system/optimus-manager.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2019-05-04 11:37:36 CEST; 13h ago
 Main PID: 714 (python)
    Tasks: 1 (limit: 4915)
   Memory: 23.4M
   CGroup: /system.slice/optimus-manager.service
           └─714 /usr/bin/python -u /usr/bin/optimus-manager-daemon

So I'm wondering if the part with "vendor preset disabled" is a problem or not but I've found nothing in the Internet.

So eventually I have no idea why the Nvidia Driver won't load, and I'm hoping anyone of you has an Idea how this problem might be solved.

PS:

This output might be interesting for you (and if any information is missing to be able to think about solving this just ask :wink: oh and I'm still not sure whether optimus-manager supports the nonfree, the free or both nvidia drivers so if someone is able to clear up this, this would be very nice ;))

pamac list -i | grep nvidia
lib32-nvidia-utils                         1:418.56-1                  multilib   100,1 MB
linux419-nvidia                            1:418.56-3                  extra      12,4 MB
mhwd-nvidia                                1:418.56-1                  core       26,6 kB
mhwd-nvidia-340xx                          340.107-1                   core       27,6 kB
mhwd-nvidia-390xx                          390.116-1                   core       26,6 kB
nvidia-utils                               1:418.56-1                  extra      209,4 MB
#2

i have no idea if this might help you, since i never used any optimus hardware with 2 gpu's,
but i've recently discovered the build-scripts by tk-glitch, which mentioned optimus compatibility, referincing the optimus-manager.
(those script's are focusing on optimizing drivers, kernel etc for gaming)
so i will just leave you this link: https://github.com/Tk-Glitch/PKGBUILDS/tree/master/nvidia-all
good luck, i hope it helps somehow.

#3

Are you sure you have read the package instructions and followed?


Please, double-check and report any news.
Also post

mhwd -li

For troubleshooting, I am not experienced in optimus-manager, so you should check your active config and logs for each boot-mode.

#4
mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
         network-r8168            2016.04.20                true            PCI


Warning: No installed USB configs!

And I've read the README.md file of the github repo (only read the post on the Manjaro wiki/forum)

#5

IIRC it says it's not compatible with bumblebee.
Are you sure you've read it?

#6

Yes definitely. This is in the manjaro wiki and forum article too. On this attempt I only disabled the bumblebee service, on the last attempt I tried to deinstall bumblebee as far as possible. (But bumblebee is actually very into the system (at least this is how I experience it, since mhwd automaticly installs it without asking) and it is possible I missed something. So if someone of you knows a place or a command to check this just respond and we'll find out :wink: )

(And annotation it would be a nice feature if mhwd would ask which solutions is desired (prime, optimus-manager, bumblebee...) after detecting an optimus system)

#7

Not at all! Just use mhwd to uninstall and install something else.
Taking precautions is a smart thing to do, read some

Not to be real for a long time, unless you believe in miracles.. :laughing:.
Apart from bumblebee and plain-nvidia, all others are not integrated to an automatic script and also difficult to do a one-fits-all solution AFAIK. Manual installation is needed.

Choose your poison!

#8

Hm yes already thought about deinstall this "video-hybrid-intel-nvidia-bumblebee" package/driver but actually when trying to uninstall I get the response, that the nvidia driver depends on this. And I want the nvidia driver but without bumblebee, this is weird.

#9

IIRC it's about nvidia-utils. Uninstall nvidia-utils first (with package manager) and try again.

1 Like
#10

Sorry to haven't replied to now. I hadn't that much time the last week but I've tried yesterday and at first uninstalled nvidia-utils and then reinstalled it. Now as far as I've seen it the optimus-manager seems to work.

Does anybody know why? (because I wonder why it works now after only reinstalle the same package)