[Optimus Manager] Switching to Nvidia leads to Blank Screen

If you set Intel to modesetting, the secondary screen will also work in Intel mode, but then you lost the ability to use Nvidia. It all depends how you use your laptop: are plugged in to AC most of time, how often do you use secondary screen, how often do you need Nvidia, etc.
Anyway, Intel modesetting, hybrid and Nvidia mode now support multimonitor setups.

1 Like

I have tried switching to Intel Only, but my monitor glitches out now and then, I mean I could’ve just lived with it, it’s not that bad, but why waste a dGPU :smirk:

Yes! I’m usually at home all day now and I have an AC supply, so I don’t have to worry about my battery dying.

A lot! The only reason I hesitated switching to Linux was because I didn’t want to waste time with Driver issues(but hey here I am, thanks to you and others that helped me). Now I can ditch Windows forverrr!

1 Like

Lol don’t do that until u have a successful case of severe borking and restoring of Manjaro from a backup or repairing with live system / rescue shell means. Gates’ crapware could be of help in case of urgent Zoom conference or whatnot.

1 Like

Haha, it was a hyperbole :sweat_smile:

In that case hybrid mode may be the best, assuming your secondary monitor works well. In that mode desktop also uses Intel but you can use Nvidia if you wish. The energy usage is higher than on pure Intel, but lower than on pure Nvidia.

Anyway, you can test it easily, since you can switch to any mode you like and set any mode as default. Optimus-manager is just convenient. However, if you are fine with hybrid mode 100% of time, then optimus-manager is not needed, since the default setup through mhwd is a hybrid one. However, on laptop it’s good to have options, just in case :slight_smile:.

1 Like

Okay, I didn’t notice this earlier but running my TV only(as a single display) in Hybrid Mode, is very laggy. With Nvidia only it works super fine. Is that how it’s supposed to be?

There is no lag when I mirror the displays, but the lag is killing me when I switch to single display. Opening nvidia-settings in hybrid mode throws this error in the console:

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

The GUI application still loads though.

In hybrid mode the default GPU is Intel. Nvidia-settings is designed to work in Nvidia mode only. Additionally, you should not use it with optimus-manager! The reason for it is, that optimus managers uses own configs in different location for each driver mode, so the usual configs must be disabled so they wouldn’t interfere. When you save settings with nvidia-settings, it writes them to the usual config, if not present, it creates a new one, which is conflicting with optimus-manager. So if you did this, check your graphical configs according to tutorial once again and disable them.

You can still manipulate Nvidia config but manually and you must know which one is from optimus-manager.

Please, read the optimus-manager documentation, especially Configuration:

As to the lag on the other monitor, I can’t help much. Each monitor is different and reacts differently to software and settings. Laptop monitors are somehow standardized. When you attach different screen, it is most likely that it will have different refresh frequencies tied to different resolutions.
You must also know that rendering additional screen is using more resources than one screen. You can see this when running a game. With secondary screen, FPS count drastically drops.

I don’t know how GPUs are handling multiple screens, but from what I see, they cause issues. For example, on my laptop all is fine and I don’t have any screen tearing, while on secondary screen is huge, so I basically can’t run any videos there. Maybe it’s because it tries to use the same frequency that is meant for laptop screen? I don’t know. Use xrandr utility (or arandr for GUI, but commandline is more powerful, see some articles about xrandr) to check your monitor properties and what settings are being used. Maybe if you tweak them for secondary screen, lag will be gone?

Multiple monitors is a headache. Especially when you try to use TV, which is way worse and less recognizable by drivers, so things may not work as expected, because many TVs were never meant to be used on computer.

It is possible that for such setups something must be added to driver configs but since in hybrid mode you use Intel modesetting (probably), you need to tweak configs for Intel modesetting, not Nvidia ones. If you switch to Nvidia mode, Nvidia probably is better suited for such situations, hence the better behavior.

1 Like

Thats a know bug and nvidia is currently working for a solution

The all new OutputSink feature aka reverse PRIME - Linux - NVIDIA Developer Forums

Reverse Prime Display = Single Display to the monitor

My workaround is to set mirror display and lower the brighness to the min on the laptop monitor,that way you sort of mimic the external display because the min brightness turn off the laptop monitor in KDE,I don’t know if GNOME can do that though.

Yup, I found a simple command in the forum:

echo 0 | sudo  tee /sys/class/backlight/intel_backlight/brightness

Just made a alias to this script, now I can run it anytime. Wrote another alias script to set brightness back too :stuck_out_tongue:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.