Optimus Manager problem : my laptop doesn't charge anymore and activates his cooling fans inopportunely

I use Optimus Manager because I have a built-in graphics card that I prefer to use in most applications. Unfortunately, I have problems : my fans turning on every 2 seconds and i can’t charge my computer while it’s in “intel gpu” mode. When my laptop is off, i can charge it

Surprisingly, when I use my RTX 2060, I have much more battery power and I can recharge my laptop.
This is the configuration of my laptop, if you need more information, I am at your disposal.

-OS: Manjaro Linux x86_64
-Host: GS66 Stealth 10SE REV:1.0
-Kernel: 5.10.15-1-MANJARO
-Shell: bash 5.1.0
-Resolution: 1920x1080
-DE: Plasma 5.20.5
-WM: KWin
-WM Theme: Breeze
-Theme: Breeze [Plasma], Breath [GTK2/3]
-Icons: breeze [Plasma], breeze [GTK2/3]
-Terminal: yakuake
-CPU: Intel i7-10750H (12) @ 5.000GHz
-GPU: Intel UHD Graphics
-GPU: NVIDIA GeForce RTX 2060 Mobile
-Memory: 1243MiB / 15825MiB

Thank you very much for your help and sorry to have an imprecise English.

Check the the wall plug and your charger and your connection points.

It looks like a fairly recent laptop - but anyway - check it for dust - clogged ventilation.

My laptop can be charged and my charger is detected. The problem comes mainly from Optimus Manager or a configuration problem.

I suggest you start with the settings for the tlp service - it can be pretty overwhelming so if not already installed - install the tlpui package.

+++ TLP Status
State = enabled
RDW state = not installed
Last run = 15:13:32, 2196 sec(s) ago
Mode = AC
Power source = AC

Notice: systemd-rfkill.service is not masked – invoke “systemctl mask systemd-rfkill.service” to correct this!

Notice: systemd-rfkill.socket is not masked – invoke “systemctl mask systemd-rfkill.socket” to correct this!

+++ Temperatures
CPU temp = 46 [°C]
Fan speed = (not available)