Optimus-Manager PRIME

When I switch to full-Nvidia on my machine, the performance is still quite bad, also PRIME Synchronisation is switched off on Nvidia settings, when I use xrandr with Nvidia modesetting=1, the screen goes black and refreshes but PRIME Synchronisation is still off, on Nvidia setting, it shows a option of X Screen 0, but the apply button is grayed out, how can i enable PRIME Synchronisation? Also should I change the it to X Screen 0 and press save to X config? Thanks for all the help!