Optimus-manager & optimus-manager-qt does not work

So lately i have been using Manjaro Linux. Yesterday i got bored and downloaded Linux Mint and noticed that now i’m addicted to pacman and aur. And decided to download Manjaro back. I downloaded Manjaro Linux KDE Plasma edition.

I downloaded the nvidia driver and optimus manager qt application. And did what arch wiki says to use only nvidia drivers for optimus manager but it seems like i cant get neither optimus manager or optimus manager qt working.

Output when i run optimus manager:

ERROR: a GPU setup was initiated but Xorg post-start hook did not run.
Log at /var/log/optimus-manager/switch/switch-20211118T102127.log
If your login manager is GDM, make sure to follow those instructions:
If your display manager is neither GDM, SDDM nor LightDM, or if you don't use one, read the wiki:
Cannot execute command because of previous errors.


[41] INFO: # Xorg pre-start hook
[41] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'integrated', 'current_mode': None}
[42] INFO: Requested mode is: integrated
[2305] INFO: Available modules: ['nouveau', 'nvidia', 'nvidia_drm', 'nvidia_modeset', 'nvidia_uvm']
[2305] INFO: Unloading modules ['nvidia_drm', 'nvidia_modeset', 'nvidia_uvm', 'nvidia'] (if loaded)
[2309] INFO: switching=none, nothing to do
[2385] INFO: Writing to /etc/X11/xorg.conf.d/10-optimus-manager.conf
[2385] INFO: Writing state {'type': 'pending_post_xorg_start', 'switch_id': '20211118T102127', 'requested_mode': 'integrated'}
[2385] INFO: Xorg pre-start hook completed successfully.

Output when i run optimus-manager-qt:

Unable to read current mode from Optimus Manager state file
[1]    8022 abort (core dumped)  optimus-manager-qt

My ‘inxi -G’ output:

Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: nvidia v: 470.63.01
           Device-3: Quanta HD User Facing type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting resolution: 1920x1080~144Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.3

It seems like i need to do this to get optimus manager working on manjaro kde. problem is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.