Optimus manager issue

Hello Everyone!
At the beginning, please treat me as ultra-noob who wish to not have windows 11, so do everything, to start with Linux. Maybe some of you will suggest me ubuntu or mint, but if at the end I will migrate to Linux, then why not Manjaro.

I wish to force my Manjaro KDE Plasma to use only nVidia. Topic older than coal.

What I did:

  1. Read Configure_Graphics_Cards on wiki
  2. Read dozens of topics in forums
  3. Broke and restore by Timeshift my Manjaro countless times

What I have now:

  1. I installed Optimus Manager, Optimus manager qt from AUR, configure it probably as expected
  2. I can switch manually between integrated/hybrid/nvidia graphic

Here’s some data about my Desktop:
Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.5
v: Lenovo Y70-70 Touch
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915 v: kernel
Device-2: NVIDIA GM107M [GeForce GTX 960M] driver: N/A

And finally my problem:

  1. If I’m on hybrid/integrated graphic, everything is ok and working fine
  2. If I’m switching to the nVidia, everything is ok, but the problem is with logging in

So first step once I turning on my Laptop, is showing black screen with some data as expected, then on Integrated/Hybrid graphic I can see loggin screen where I’m inputting login, hit enter and voila.
Funny story is with nVidia card. Once black screen with some data disappear, then I can see black screen…but it’s not black screen indeed, just the Login screen is not displaying, however if I will ignore it, input password and hit enter, then mouse, desktop and all stuff will display normally.

So long story short: loging desktop is not displaying, but run normally, so there is no situation where some process is not executed i guess.

Strange as hell.

Fun fact: Doesn’t matter whether I will have installed video-hybrid-intel-nvidia-prime, or nvidia-390xx-bumblebee, or just video-nvidia, or vide-nvidia-390xx.

All the time is the same: login screen is run but not displayed when Optimus is switched to nVidia.

Please, tell me that this issue is easy to solved :smiley:

Now if you have any questions, please ask. I’m sure that I did not provided all important data, but don’t know what is important for you.

Ok, I solved my issue.

I forgot to change one thing. For those who might have same problem, please:

  1. Go to the /etc/
  2. Find DisplayCommand and DisplayStopCommand, input # just before and save.

Hope it will be helpfull for someone.

I just marked this thread as solved for you.

For the next time you post on the forum, format your command output. There is a discourse tutorial on formatting your posts around, if you haven’t received a tutorial yet as a PM. :+1:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.