Optimus-manager in "integrated" mode

Hi everyone, I have a Lenovo Legion 5 and I installed optimus-manager in order to have HDMI working with the “hybrid” mode. However, I don’t always use HDMI, and in that times I would like to use the “integrated” mode in order to don’t use my Nvidia GPU at all (save battery).

I can switch with no problems, but apparently my GPU is still detected (is still running). Blender can detect and use my GPU, for example. Isn’t optimus-manager in “integrated” mode supposed to completely power off my GPU?

Am I missing something? Thanks in advance, ask me anything.

> inxi -G
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    v: 520.56.06
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    dri: radeonsi gpu: amdgpu resolution: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon Graphics (renoir LLVM
    14.0.6 DRM 3.48 6.0.8-1-MANJARO)
> optimus-manager --status
Optimus Manager (Client) version 1.4

Current GPU mode : integrated
GPU mode requested for next login : no change
GPU at startup : hybrid
Temporary config path: no

In the right setup, the GPU will not be active all the time even in hybrid mode. E.g. check if

cat /proc/driver/nvidia/gpus/*/power


Runtime D3 status:          Enabled (fine-grained)

This can be enabled by setting


in the optimus-manager configuration (/etc/optimus-manager/optimus-manager.conf).

is still running

Is that what

cat /sys/bus/pci/devices/0000\:01\:00.*/power/runtime_status

says? (Where 0000:01:00.* is the address of the devices on the nvidia gpu - you can run lspci find out, but usually nvidia gpu is at the above address on laptops.)

Runtime D3 status:          Enabled (fine-grained)
Video Memory:               Off

GPU Hardware Support:
 Video Memory Self Refresh: Supported
 Video Memory Off:          Supported

Power Limits:
 Default:                   N/A milliwatts
 GPU Boost:                 N/A milliwatts

So I suppose D3 is ok.

> cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status

When using Blender, it turns to “active”.

Don’t get me wrong, my system is working fine, but I expected that the “integrated” mode would completely power off my Nvidia card, in order to save battery.


That only applies to the display configuration, using CUDA, etc. can still power up the GPU – as far as I’m aware.

Thanks, I didn’t know that.
Can you redirect me for some docs or more info regarding that topic?

Again, thanks for your time.

Maybe these two:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.