Optimus-manager app won't open

Followed Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA) mostly successfully. However, 2 problems.

  1. I open "Optimus Manager" (the settings app), nothing happens. No window opens.

  2. I can't find out where/how to truly disable the dGPU once I'm in Intel mode, so I suffer the huge power draw despite being on the supposedly "energy-efficient" Intel-only mode.

How do you open the settings app?

In theory, the switch to Intel mode deactivates nvidia. If that is not the case, the switch alone wasn't fully successful. What switch method do you use?

Check powertop to see if nvidia is really on during Intel mode and check if you are really in Intel mode.

I would windows key to launcher, start typing "optimus manager", and click it or press enter, how you launch apps. I could also use terminal. Same result: nothing.

I got around it by installing the gnome extension widget, but I was never able to open the optimus-manager settings app.

I uninstalled optimus and went back to bb so I could deactivate nvidia, as it's not disableable (in optimus) on lots of Dells, mine included.

I was really in intel mode, and nvidia was really on. It approximately doubles the power draw, and doesn't show up in powertop, so it's painfully easy to see: total normal idle draw is around 8-11W, depending on how idle my idle is, and in Optimus Intel mode, it would never draw below 18W, because the Nvidia chip is sucking another ~10W constantly. No processes in powertop account for the ~10W. It's just the Nvidia package sucking power for nothing.

Until you find better solution, try nvidia-xrun that supports vulkan:

I successfully finished Witcher 3 on that setup (I had bumblebee as default and then used nvidia-xrun to start steam), so despite some overhead, it's still better then bumblebee.

Forum kindly sponsored by