Optimus laptop issues


#61

thank you, i think my brain is melting :crazy_face:


#62

Ok now I’m confused - it worked only once, after next reboot it doesn’t do anything (gpu is on, touchpad is working)…

lspci | grep 3D NV
grep: NV: Nie ma takiego pliku ani katalogu (no such file or directory)

also I can’t echo '\_SB.PCI0.PEG0.PEGP._ON' > /proc/acpi/call (or off), it says I have no access even with sudo

@petsam I will try that next I think


#63

yes, because to make it persistent a few further steps are needed to make it disable at boot. besides i think @petsam 's idea is a bit more on the side of sanity (at least mine anyway :grin:)

like i said, brain melting… i meant to write 3D or NV not both. my bad.
lscpi | grep 3D is what i meant


#64

I edited my previous post (added blacklist nouveau).
I think it’s needed, since you don’t want any use of nvidia card.
If it creates conflict, maybe disable then, but I suggest you try it first.


#65

I’ve set it up as you suggested, it gives me black screen freeze after login unless I put acpi_osi=! acpi_osi=“Windows 2009” in grub… Touchpad not working again. It is getting a little bit ridiculous now


#66

Are you on bumblebee?
My advice was for free drivers.


#67

Nope, I’m on video-linux


#68

Do you also have this at grub?


#69

I’ve tried with it, then without, then acpi_osi=… and only the last one got me into X session


#70

i think that would be the acpi_osi=! thats doing it because the syntax on
acpi_osi=“Windows 2009” is wrong i believe and would just be ignored IIRC. either way you shouldnt need them for the free drivers. possibly something loading from the acpi_call method you were trying before?

/etc/modules-load.d/acpi_call.conf
and
/etc/tmpfiles.d/acpi_call.conf

@petsam does acpi_call and acpi_osi=! cancel each other out?


#71

I removed those, and uninstalled acpi_call. Also isn’t bbswitch used by bumblebee? Maybe that’s the part that causes the need of acpi_osi= usage in the first place?


#72

Please check the logs while in TTY. How does this fail, when it worked just before?
Maybe remove blacklist nouveau.
Anyway, check logs

journalctl -b -p3
less /var/log/Xorg.0.log

#73

Not necessary, bbswitch can be used alone.


#74

Yes, but maybe it’s not bumblebee that causes those issues but bbswitch? I mean everyone (and there is a lot of reports of users in need of adding acpi_osi params to boot) is using bumblebee but maybe the issue is not with bumblebee alone but bbswitch itself


#75

That’s assumptions. That’s why we need logs for proof. :wink:


#76
journalctl -b -p3
-- Logs begin at Sun 2019-01-27 05:29:12 CET, end at Wed 2019-01-30 02:40:18 CET. --
sty 30 02:24:53 jakub-pc bluetoothd[461]: Failed to set mode: Blocked through rfkill (0x12)
sty 30 02:24:57 jakub-pc bluetoothd[461]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Ad>
sty 30 02:24:57 jakub-pc bluetoothd[461]: RFCOMM server failed for :1.158/Profile/HSPHSProfile/00001108-0>
sty 30 02:24:59 jakub-pc bluetoothd[461]: Failed to set mode: Blocked through rfkill (0x12)

Just connecting the dots :wink: is this what you wanted?


#77

It doesn’t give anything. Was it proper?
We need
acpi* removed from grub command line
boot to black screen
go to TTY
run commands for journal and Xorg logs and post.
Howto in tutorial (if needed)


#78

dont forget to update-grub after editing


#79

@petsam doesnt bbswitch rely on acpi_call to function?


#80

AFAIK no. Even checked dependencies…