Optimale Einstellungen für Nvidia


#1

Hi,

da mein System nun soweit eingerichtet ist geht es an die Feinjustierung. Aktuell nervt mich ein wenig, dass der Arbeitsflächenumschalter (Würfel) etwas ruckelt. Ich benutze diesen aber gerne und oft.
Am Anfang hatte ich im Treiber die “force composition pipeline” aktiviert.
Dann den Triple Buffer aktiviert.
Und nun " /etc/profile.d/kwin.sh"
Open GL 3.1 usw. ist auch aktiviert
Trotzdem werden die Animationen nie 100% flüssig.

Hat jemand empfehlenswerte Einstellungen die ich nehmen kann? Oder gibte es hier garkeine Schraube an der man drehen kann?

Ich habe mich auch schon gefragt ob es klug wäre in Zukunft AMD zu nehmen, aber was man so liest im Internet scheint Nvidia für Linux garnicht mehr so schlecht zu sein?!

Ich bin überfordert :wink:

Grüße

Mein System
Core i7 7700K
SSD 970 Pro 1TB
EVGA GTX 1080 Ti FTW3


#2

Ich habe eine GTX 1070 und hier läuft KDE super flüssig.

Ich benutze kein FFCP (und ich empfehle es zu deaktivieren), sondern KWIN_TRIPLE_BUFFER=1 in kwin.sh.

Ausserdem sollte man sicherstellen das __GL_SYNC_TO_VBLANK=1 aktiviert ist. Das ist normalerweise sowieso schon der Fall.

Allerdings benutze ich diesen Würfel nicht, deshalb kann ich dazu nix sagen.

Verwendest du nur einen Monitor? Wenn ja, ein klassischer 60 Hz?


#3

Hi,

ja ich nutze einen 21:9 Monitor der mit 75 Hz bzw. 60 Hz läuft.
Kannst du das etwas genauer erklären? Also wo ich was einstellen muss?
Füge ich KWIN_TRIPLE_BUFFER=und __GL_SYNC_TO_VBLANK=1 einfach in meine kwin.sh ein?
Gibt es eine Möglichkeit zu testen ob die Funktionen greifen?

Dank dir.


#4

Es sind beides Variablen.
Ich bin aktuell nicht auf KDE, aber ich würde zunächst einmal
export KWIN_TRIPLE_BUFFER=1
in die kwin.sh einfügen. Es könnte sein dass das bereits ausreichend ist.

Abfragen kann man mit echo $KWIN_TRIPLE_BUFFER.


#5

Perfekt! Ich danke dir.
Nachdem ich beide Werte in die kwin.sh eingetragen habe ist das stottern zu 99% verschwunden.