Opinions on Manjaro Architect? And what can improve?


Yeah, it’s a pain in the ass if you miss any steps. Happened to me too time or three. To check, did you go through user creation and user was not created? I’d like to catch it if it’s a bug.

The installer really comes to its own if you can use it with pacman cache and configured system. Not ideal for a live ISO.


If I am not wrong I followed every step. Because I tried 3 times consecutively as, one time I just marked one mirror not knowingly. I can’t be :100: sure but I checked multiple times.


Do you remember actually typing in a root password, user name, password, zsh/bash/fish options yourself though? The root password was first, then the next step included the rest.


Hmm… So you entered username and password, but no user was created. What shell did you choose (zsh/fish/bash)?


@Chrysostomus no I didn’t. I may have missed somehow. I was left with the impression that I had to do that using the command.


Ah, then there is the mishap :slight_smile:

  1. Prepare Installation
  2. Install Base
  3. Configure Base

These were the last steps of the installation process:

  • Configure Base
    • Create fstab
    • Set Hostname
    • Set Locale
    • Set Desktop Keyboard Layout
    • Set Timezone and Clock
    • Set Root Password
    • Add New User(s)

The tutorial shows this step too.


I would say, make root and user creation mandatory somehow. It is possible to miss it and then you can just miss the warning at the end.


This is what it should look like:


Why does your background so blue? Isn’t the installer usually dark? o o"

Or is this a new version? (I do prefer the dark)


I think that is user responsibility. Someone can want to have passwordless root or no user accounts. There is a notification of this, so that it would be a consicous choice. But I think this is a installer that should not prevent you from making bad choices.

Of course, if there is a public opinion or good arguments that we should go towards more foolproof direction, I am open to the idea.

@realmain It depends on your dotfiles and terminal colors. You can set it the way you like, I just left mine unconfigured.


Then after you realease the next version, I will give it another go.
@realmain Thanks for clearing it up.


I generally agree with user responsibility. But I cannot think of any use case for:

And it is really possible to miss the last warning, I almost missed it the last time myself.
However missing this step can be fixed with passwd and useradd after the install, or just restarting manjaro-architect, mounting the target and then running Set Root password and Add new users.


Although, mounting the target is kinda difficult if you installed on btrfs subvolumes. Then you pretty much have to do it manually. This is something wish could be improved.


Hello all! I’ve been lurking here for a while, after having installed Manjaro on most of my computers. I normally prefer Arch… but the nice, clean, minimal look and fast installs of Manjaro brought me here.

Anyway, I have some issue to report with the Architect installer. I keep running into a “255”-error when trying to install Desktop packages, stating “/mnt too full” - even though it is not. This happens with both systemd/openrc, and LXDE or LXQt.
This seems to be a pacstrap bug, and it’s reported here:

Someone claims disabling DiskSpace-check in /etc/pacman.conf to be a workaround. I tried this by using the “chroot into install” -option in the installer and editing pacman.conf, but it seems to mess up (halt) the install-process. (Maybe because I typed “exit” when leaving the terminal, which also made me exit the Setup.) Does anyone know another way to fix this?

Computer is an Acer Aspire One 522 netbook, 1 GB ram. Makes no difference how I partition, manually or automatically. Bios and partitioning is non-UEFI.


What branch are you using? Sometimes this happens on testing and unstable branches


Dev Stable. Sorry I forgot to mention that.


The chroot option should advise you to run


After exiting chroot to return to installer. I take it that it does not do this.

Easier way to modify configuration is

  1. use the option under configuration menu. (item 5 in main menu I think)
  2. edit /mnt/etc/pacman.conf from the host system.


i installed the latest m-a a (iso) couple days ago, and even though I selected LXDE-full-desktop, us-english,…, I ended up with a spanish-only LXDE desktop?
But that’s ok, maybe I should expand my horizons. :wink:


Interesting. The locale entries are close together,i also misclicked a time or two.


I have done that before i chose es-us instead of en-us