Operating [solved]system not loading when WIFI card is removed from the motherboard

You need to turn the card off in bios then it should boot the motherboard is trying to non existent hardware

@mandog hello mandog i searched every section of my laptop bios there is no option to turn it off

only these options there in the bios also it is the latest for my mobo

that is just the settings for boot check in system configuration look for Lan

everything is infront of u, no other settings present in bios

How much ram do you have by the way

If live boot works fine, gimme your

inxi -Fx

8GB RAM, 2 sticks of 4GB

[manjaro@manjaro-cinnamon ~]$ inxi -Fi System: Host: manjaro-cinnamon Kernel: 4.4.13-1-MANJARO x86_64 (64 bit) Desktop: Cinnamon 3.0.5 Distro: Manjaro Linux Machine: System: Hewlett-Packard (portable) product: HP Pavilion G6 Notebook PC v: 0792100000205610000610100 Mobo: Hewlett-Packard model: 184A v: 57.35 Bios: Insyde v: F.26 date: 02/21/2013 Battery BAT0: charge: 36.5 Wh 89.1% condition: 41.0/41.0 Wh (100%) CPU: Quad core AMD A8-4500M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB clock speeds: max: 1900 MHz 1: 1600 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7640G] Card-2: Advanced Micro Devices [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] Display Server: X.Org 1.17.4 driver: radeon Resolution: 1366x768@59.99hz GLX Renderer: Gallium 0.4 on AMD ARUBA (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.2 Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller driver: snd_hda_intel Sound: Advanced Linux Sound Architecture v: k4.4.13-1-MANJARO Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k IF: wlo1 state: down mac: 44:6d:57:83:9d:72 Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169 IF: eno1 state: down mac: 00:00:00:00:00:00 Card-3: Atheros IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A WAN IP: None Detected! IF: wlo1 ip-v4: N/A IF: eno1 ip-v4: N/A Drives: HDD Total Size: 771.7GB (25.6% used) ID-1: /dev/sdb model: ST500LM012_HN size: 500.1GB ID-2: /dev/sda model: Samsung_SSD_850 size: 256.1GB ID-3: USB /dev/sdc model: Ultra size: 15.6GB Partition: ID-1: / size: 5.5G used: 7.5M (1%) fs: overlay dev: N/A ID-2: swap-1 size: 8.20GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3 Sensors: None detected - is lm-sensors installed and configured? Info: Processes: 183 Uptime: 1 min Memory: 488.5/7461.4MB Client: Shell (bash) inxi: 2.3.0

did you make any changes in /etc/modules-load.d or modprobe.d to enable your wi-fi card ? undo it.
or you could add a *.conf file to blacklist ath9k module.

Boot to live and check your root partition’s /etc (not live’s /etc) for these folders.

Ohh OK thanks I will do it and confirm if it works or not

No I haven’t done any changes

Then blacklist ath9k module, instructions here
https://wiki.archlinux.org/index.php/Kernel_modules#Blacklisting

fixed
removed the wifi card
attached the usb wifi dongle
did a clean install of manjaro kde
everything works fine now
@badbodh blacklisting didnt worked bro
anyways thank you to all

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.