Openrc upgrade - elogind

Yeah that worked but I had to remove a few other things after than and then run the update. In the end CUPS was messed up and I had to run HPLIP again. I’m sure there will be more shake out as well, but the upgrade did go forward.

I have 2 servers that also need to navigate this upgrade, and it is just not possible. I just end up removing deeper and deeper into the system by hand, and the update itself has a mirrors update. I can’t get past a broken signature on jasper. I’m stuck wiping the server clean and starting again.

[manjaro ~]# pacman -Syu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace eudev-systemdcompat with community/eudev-systemd? [Y/n] Y
:: Replace eudev-systemdcompat with community/libeudev-systemd? [Y/n] Y
:: Replace fuse with extra/fuse2? [Y/n] Y
:: Replace manjaro-documentation with extra/manjaro-documentation-en? [Y/n] Y
:: Replace pacman-mirrorlist with core/pacman-mirrors? [Y/n] Y
:: Replace pm-quirks with community/pm-utils? [Y/n] Y
resolving dependencies…
looking for conflicting packages…
warning: removing ‘libusb’ from target list because it conflicts with 'libusb-nosystemd’
warning: removing ‘device-mapper’ from target list because it conflicts with 'device-mapper-nosystemd’
warning: removing ‘cups’ from target list because it conflicts with 'cups-nosystemd’
warning: removing ‘dhcpcd’ from target list because it conflicts with 'dhcpcd-nosystemd’
warning: removing ‘lvm2’ from target list because it conflicts with 'lvm2-nosystemd’
warning: removing ‘rpcbind’ from target list because it conflicts with 'rpcbind-nosystemd’
warning: removing ‘syslog-ng’ from target list because it conflicts with ‘syslog-ng-nosystemd’
:: device-mapper-nosystemd and device-mapper are in conflict. Remove device-mapper? [y/N] y
:: cups-nosystemd and cups are in conflict. Remove cups? [y/N] y
:: libusb-nosystemd and libusb are in conflict (libusbx). Remove libusb? [y/N] y
:: dhcpcd-nosystemd and dhcpcd are in conflict. Remove dhcpcd? [y/N] y
:: qt5-base and qtchooser are in conflict. Remove qtchooser? [y/N] y
:: lvm2-nosystemd and lvm2 are in conflict. Remove lvm2? [y/N] y
:: rpcbind-nosystemd and rpcbind are in conflict. Remove rpcbind? [y/N] y
:: syslog-ng-nosystemd and syslog-ng are in conflict. Remove syslog-ng? [y/N] y
:: pm-utils and elogind are in conflict. Remove elogind? [y/N] y
:: pm-utils and tlp are in conflict. Remove tlp? [y/N] y
:: xorg-server and xf86-input-acecad are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-acecad? [y/N] y
:: xorg-server and xf86-input-aiptek are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-aiptek? [y/N] y
:: xorg-server and xf86-input-joystick are in conflict (X-ABI-XINPUT_VERSION). Remove xf86-input-joystick? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: elogind-openrc: removing elogind breaks dependency ‘elogind’

(507/507) checking package integrity [##################################################] 100%
error: jasper: signature from “Levente Polyak (anthraxx) levente@leventepolyak.net” is unknown trust
:: File /var/cache/pacman/pkg/jasper-2.0.13-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

I see that you spamming a lot of y for this hehe…
You really shouldn’t, because I can see that you also pressed Y for removing elogind

pm-utils and elogind are in conflict. Remove elogind? [y/N] y

Which is weird…

Maybe you should follow @aaditya’s master guide before updating?



Also why not just to reinstall your system using manjaro latest iso and migrate to openRC from there…

I have successfully fully migrated to openRC using Systemd free guide and PAMAC lel (and little bit from manjaro wiki)

I can help you migrate to openrc from there should you reinstalled your system using latest iso

But hey it is up to you to choose the workaround for this…

Perhaps English is not your primary language, but it is very difficult to understand what you wrote here.

Okay let’s start with this…Why you do this?

pm-utils and elogind are in conflict. Remove elogind? [y/N] y

I thought my english was fine…

Don’t remove elogind. It looks like you need to remove pm-utils first (elogind can handle suspend and hibernate instead). Then try the update again.

yeah I tried that, as per the original solution, but I couldn’t remove pm-utils. It had too many dependencies.

I even tried just removing all of x11 but I couldn’t figure that out either. I suppose there are a series of groups. I don’t need X11 for my server/

Did you tried to even atleast read my reply to yours?? What part of “english” that you really don’t understand??

It is saddening to see that you dismissed another solution just because you couldn’t read properly. Oh well…

Thanks for trying to help, but I already wiped the system clean and reinstalled from scratch. Such a luxury might not be readily available in the future with that system since it is scheduled to go on line as the primary webserver once the image is copied over, which will take some time.

if you say N, it pretty much just aborts the upgrade.

Which is why I recommended you to follow @ aaditya guide before updating because it handles this kind of conflicts…

Also if you got confused with someone, at least point out that got confused you in first place. And don’t try discouraging anyone like that…

This is my communications network and not a toy. Prior to my coming here to post a question, that means I’ve already spend at least 2 hours debugging the problem and researching it. When I post a question, it is a rather desperate act on my part already and a serious issue. I have been polite, but here I drawn the line.

I appreciate that you take your time to try to answer questions and tech support is never free, so I appreciate it it double. But it is YOUR responsibility to speak clearly and to be be understood. By the time you logged your question, I had already ready aatiya’s post, and a few dozen others on this topic.

At no time have I tried to discourage participation, particularly yours. But you have made a couple of GROSS misunderstandings, starting with this idea that I am migrating from systemd to openrc. I’m been using openrc for maybe 2 years now. It has hasn’t always been a smooth upgrade and aatiya’s method is frankly not conducive to running a live system that is delivering services. pacman -Syu needs to work fairly smoothly. Usually problems can be fairly quickly sorted out, but not in this case. That server is trying to upgrade several steps at one time and the last openrc transition has been in a somewhat new direction.

Regardless, there is no reason to get bent out of shape, at least there is no reason I gave you. Before you gave your answer, I already made an executive decision based on previous discussions over the last two weeks with the openrc development team. It is not like I could wait two days for a solution to appear. I had to get that box back up and running so I wiped it, which is definitely a suboptimal solution, but it is occasionally a necessity.

Yeah that was an arrogant thing to say, even child like. I let it pass at first, but since you are making a big deal of nothing, I suggest you start by not posting this kind of message. If you’re making a technical observation, make it like an adult, and be clear about what you mean.

The reason for saying yes is two fold:
A) Because the upgrade doesn’t move forward otherwise
B) This is part of the latest new direction that the distro is moving. But in the end, I couldn’t coax pacman into do this upgrade, the last effort ended up with the signature of jasper being a problem, and it being impossible to remove without a cascade of a dozen or more dependencies. Updating the mirrors didn’t help either. In the end, pacman was broken and I could either rebuild pacman from a latest working live disk, or just reinstalling. I had the luxury of being able to reinstall in the case, so I did.

This is actually of one of my attempt of making joke. But, you see it as an arrogant attitude of me. So I apologize for this, and try to be making clear this time

And no. I’m not making a big deal of nothing. I was recommending @ aaditya guide because, again it was based on my assumptions that you have conflicting elogind and pm-utils . I didn’t know that you also have had hard time removing package without its dependencies. I could have suggested you to use sudo pacman -Rncs <name_of_the_package>. This will remove the package as well others package that using it as dependency, resulting in easy removing…

At least you successfully reinstall this. I’m glad for it

That conflict seems to be on all my systems and I’m not sure if that is unique to me, and maybe my using wmaker from the arch community database or something else, or just a function of my using this base for a long time. Last time we were able to just remove the pm modules, but this time that failed to work.

sudo pacman -Rncs is an idiom I’ll remember and I thank you for it.

I tried --force and those didn’t work much as all.

I did have trouble understanding your original posting and i was sincere about the language, but I didn’t mean it to be insulting. I was aware it could be and I tried to make it as soft as possible. Evidently I failed.

I need to understand that this forum is very international and many great contributors here use English as a second or third language. So the question was sincere.

Again, thank you for all your time on this matter.

Ruben

1 Like

This is not really unique. This is actually @ artoo 's attempt to automate switching from consolekit to elogind when updating using some kind of script (I think). Heres the thread that start it :

I’ll have to remind that you need to see the packages that got removed with it. It could be one of your favorite softwares or important ones. So you need to be really careful with it…

1 Like

I prefer -Rdd that only removes one package but of course may leave crud behind but to my mind safer in the first instance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark