Opening X programs as root very slow

Not sure if this is a cinnamon or a general issue, but since a few days I noticed a large delay when running GUI executables as root. “sudo xed strange.txt” for example needs up to 30 seconds to open after password input, while “sudo nano strange.txt” opens immediately. This happens only the first time, subsequent calls have no delays. The same delay occurs when opening a folder as root in Nemo. I only found hints regarding wrong host name in /etc/hosts, but the host name there is correct. So any ideas what this could be?

try using the admin protocol

xed admin:/etc/fstab

Below is from the archived forum instance

1 Like

I have this call already in my nemo actions (Exec=xed admin://%F). With admin protocol there is no delay. But the problem remains using sudo. By the way, also pkexec has this issue. I guess there is something misconfigured, but I have no idea what.

Don’t do that with sudo. See also Running GUI applications as root - ArchWiki

@linux-aarhus has a very good example above.

1 Like

I’ve marked this answer as the solution to your question as it is very dangerous what you’re trying to do and also explained again here.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

sudo was never designed to run GUI applications so there is nothing misconfigured - just an old habit having a hard time dying.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.