Opening a file from SMB share in Files stopped working

Double-clicking a file on SMB share in Files stopped working. It used to work with all apps, and I think this is because Files mounted the shared directory into a local path under the hood. Now, almost all apps fails to load files and VLC shows a message box that says that it could not open “smb://…”. Judging by the message, for some reason, double clicking a file passes the raw SMB protocol path to applications instead of a mounted path.

How to fix this? I do not remember changing any SMB settings manually, so I am not sure why it stopped working.

Meh, never mind. There was a big update (about 750MB) today, and when I run the update, Gnome’s version became 41.5 and suddenly opening file from SMB shares started working again. I guess there was a bug in Gnome somehow.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.