OpenGL not working after update

Issue:
Since updating this morning OpenGl has stopped working.

Logs:

  • inxi
System:    Host: etienne Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.3 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450-A PRO (MS-7B86) v: 2.0 serial: <filter> UEFI: American Megatrends 
           v: A.70 date: 03/06/2019 
CPU:       Topology: Quad Core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP arch: Zen 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 28010 
           Speed: 1423 MHz min/max: 1600/3500 MHz Core speeds (MHz): 1: 1512 2: 1424 3: 1396 4: 1383 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] vendor: Micro-Star MSI 
           driver: amdgpu v: kernel bus ID: 10:00.0 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati unloaded: modesetting resolution: 1680x1050~60Hz 
           OpenGL: renderer: N/A v: N/A direct render: N/A 
Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 38:00.6 
           Sound Server: ALSA v: k5.0.5-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: e000 bus ID: 18:00.0 
           IF: enp24s0 state: down mac: <filter> 
           Device-2: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee v: kernel port: d000 bus ID: 1c:00.0 
           IF: wlp28s0 state: up mac: <filter> 
Drives:    Local Storage: total: 577.55 GiB used: 53.39 GiB (9.2%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB 
Partition: ID-1: / size: 79.74 GiB used: 10.38 GiB (13.0%) fs: ext4 dev: /dev/sdb3 
           ID-2: /home size: 457.45 GiB used: 43.01 GiB (9.4%) fs: ext4 dev: /dev/sda1 
           ID-3: swap-1 size: 29.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 45.2 C mobo: N/A gpu: amdgpu temp: 34 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1046 
Info:      Processes: 225 Uptime: 3m Memory: 15.67 GiB used: 1.35 GiB (8.6%) Init: systemd Compilers: gcc: 8.2.1 Shell: zsh 
           v: 5.7.1 inxi: 3.0.32

As seen here opengl has no renderer.

  • glxinfo
name of display: :0
Error: couldn't find RGB GLX visual or fbconfig
  • journalctl -p3 (latest boot)
Apr 06 12:45:51 etienne kernel: AMD-Vi: Unable to write to IOMMU perf counter.
Apr 06 12:45:52 etienne kernel: sp5100-tco sp5100-tco: Watchdog hardware is disabled
Apr 06 12:46:45 etienne kwin_x11[909]: kwin_core: choose config failed
Apr 06 12:46:45 etienne kwin_x11[909]: kwin_core: Creating egl surface failed

I think the 2 first lines were present before.

What I have tried:
I searched for this error on the forums and most of the solutions were to do with rebooting or reinstalling some packages. I reinstalled the packages I saw mentioned but I didn’t keep track of which.
I’ve also reinstalled the drivers using

sudo mhwd -f -i pci video-linux

but even after rebooting that didn’t help.

Any help is appreciated!

In short:

sudo pacman -Syyuu

Thank you!
It installed a couple of mesa libraries and now it works!
What exactly does

sudo pacman -Syyuu

do?
I thought -y was refreshing the database and -u would perform the update.
I had used -Syu to perform the update so what would be the difference in this case?

-yy forces package list/database refresh, even if it’s up-to-date.
-uu upgrades packages and also downgrades packages (if you happen to have a newer local version than the one in the repository)

In this case it wasn’t really a downgrade, since it was a matter of "naming " of the packages and the use of an “epoch” to circumvent an issue, but still, that’s the gist of it. This is a special case scenario, you usually don’t need to use that command.

It’s more or less explained in the second post of the announcement thread, like usual:

1 Like
man pacman

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark