OpenGL Grayscale Color


Can anyone advise on this problem? Seems like the display turn grayscale with OpenGL 2.0 or OpenGL 3.1.

System:    Host: Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: X570 AORUS ELITE WIFI v: -CF serial: <superuser/root required> 
           Mobo: Gigabyte model: X570 AORUS ELITE WIFI v: x.x serial: <superuser/root required> UEFI: American Megatrends 
           v: F30 date: 09/15/2020 
CPU:       Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 2549 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2229 2: 2149 3: 2154 4: 2093 5: 4303 6: 2157 7: 2149 
           8: 2158 9: 2102 10: 1994 11: 4300 12: 2157 13: 2141 14: 2157 15: 2672 16: 1976 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] driver: nouveau v: kernel 
           Display: x11 server: X.Org 1.20.10 driver: modesetting,nouveau resolution: 2560x1440~144Hz 
           OpenGL: renderer: NV166 v: 4.3 Mesa 20.2.3 
Audio:     Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
           Device-3: SAVITECH SA9023 audio controller type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp6s0 state: down mac: b6:a3:37:73:25:22 
           Device-2: Intel I211 Gigabit Network driver: igb 
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: 18:c0:4d:1d:af:90 
           Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
Drives:    Local Storage: total: 13.32 TiB used: 16.60 GiB (0.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB 
           ID-2: /dev/nvme1n1 vendor: Crucial model: CT500P1SSD8 size: 465.76 GiB 
           ID-3: /dev/nvme2n1 vendor: Toshiba model: N/A size: 238.47 GiB 
           ID-4: /dev/sda vendor: A-Data model: SU800NS38 size: 476.94 GiB 
           ID-5: /dev/sdb vendor: Toshiba model: MD04ACA400 size: 3.64 TiB 
           ID-6: /dev/sdc vendor: Toshiba model: MD04ABA400V size: 3.64 TiB 
           ID-7: /dev/sdd vendor: Western Digital model: WD40EZRZ-00GXCB0 size: 3.64 TiB 
           ID-8: /dev/sde vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
           ID-9: /dev/sdf type: USB vendor: SanDisk model: Extreme Pro size: 119.25 GiB 
Partition: ID-1: / size: 116.58 GiB used: 16.60 GiB (14.2%) fs: ext4 dev: /dev/dm-0 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 66.2 C mobo: 16.8 C gpu: nouveau temp: 35.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 938 
Info:      Processes: 371 Uptime: 24m Memory: 15.64 GiB used: 1.79 GiB (11.4%) Shell: Zsh inxi: 3.1.08

I cannot upload screenshot but basically if I select OpenGL as compositor, the screen will turn grayscale, but if I use Xrender, the color back to normal. Is this problem common?

Hi and welcome to the forum :+1:

Did you try with the proprietary nVidia driver also?
Seems to me you are using nouveau instead, which might be causing it.

Hi Trimoon, I tried your suggestion but seems like the problem still persist. Installed 455 and restarted. Still grayscale color with OpenGL option.

Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] driver: nvidia v: 455.45.01 
           Display: x11 server: X.Org 1.20.10 driver: nvidia resolution: 2560x1440~144Hz

OK fixed it. Seems like I accidentally activated Grayscale effects in kwin. Sorry about that. Thanks for the help. :sweat_smile:

Well that’s the edge of my knowledge wrt OpenGL and this context then :face_with_hand_over_mouth:
Did you try to search on the nVidia forums if anyone else has similar issues?
If i’m not wrong this is there forum right?

No problem we all make mistakes, we’re all human after all :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.