OpenCL doesn't work in Lightworks




I’m really trying my best to get away from Windows/macOS however in order to do so I need a professional grade NLE, like lightworks. Luckily lightworks is in the AUR but unfortunately there seems to be a bug either in lightworks or the nvidia driver that makes openCL not working right within lightworks, as playback is absolutely garbage. It’s not a performance issue as I’ve tried a gtx 680 and a Titan X, with both cards I can’t edit even 720p videos.
I’m running the latest available proprietary nvidia driver, even cuda is installed. If someone has/had the same problem and managed to fix it, please share it with me.

Thanks for reading.


Are you running with just the Nvidia driver, or using hybrid graphics under Bumblebee/PRIME? If you’re running bumblebee, for example, you’ll have to run the application with e.g. primusrun lightworks to get the card to kick in.


I solved the problem, it was the codec. It HAS to be a mp4 video with the mpeg2 encoder, apparently every other codec is not editing friendly enough. Which is really weired since DNxHD/HR ran also like ■■■■. Lightworks is not codec friendly, despite being advertised as such.


Iirc paid version is quite more advanced on that front.
If you work with free one, I remember there were codec tweaking programs on the forums, or something


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.