openCL and NVIDIA 730 GT

Hi there,

I would like to use openCL for darktable and have installed a nvidia 730 GT in my PC. However, I cannot get clinfo to show a platform, so I was hoping that someone here could give me a hint. What I found so far is that a version mismatch between drivers might be a problem (

Removing everything and starting with installing cuda first however seems to install some dependencies that prohibit me from installing any nvidia drivers afterwards (I guess).

sudo mhwd -i pci video-nvidia-470xx

at least shows an error, as video-hybrid-intel-nvidia-470xx-prime is already installed. I cannot remove it as it would break nvidia-utils which are required by cuda.

Any help and hints are appreciated!

Since Cuda is optional, I suggest you start over, first remove Cuda and whatever dependencies it installed with it, install your nvidia driver using manjaro hardware configuration tool, then reinstall cuda.

Yes, that’s what I figured as well (so far :D). I just installed CUDA as I thought it might be needed to have openCL after it did not work initially.

I removed everything and installed the drivers as described here: Configure NVIDIA (non-free) settings and load them on Startup - Manjaro

As a graphics card it is working now. Afterwards I installed opencl-nvidia as described here: GPGPU - ArchWiki

Unfortunately, clinfo still shows no running platforms.

Out of curiosity I installed intel-opencl from AUR as this supports my CPU. This results in a platform which is found by clinfo.

Do I have to activate the opencl platform somewhere?

In a hunch I changed my kernel from 5.15 to 5.10 LTS in hope for better driver support, but no luck.

These are the nvidia packages that I have currently installed (pacman -Q | grep nvidia):

lib32-nvidia-470xx-utils 470.94-1
linux510-nvidia-470xx 470.94-6
mhwd-nvidia 495.44-5
mhwd-nvidia-390xx 390.147-2
mhwd-nvidia-470xx 470.94-1
nvidia-470xx-utils 470.94-2
opencl-nvidia 495.44-5

clinfo still shows no openCL platform available.

Someone on reddit found the solution: The version of opencl-nvidia did not match the driver versions. Removing opencl-nvidia and installing opencl-nvidia-470xx from AUR solved the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.