[openbox] iso rebuild

community-edition
openbox

#1

Openbox ISO rebuild

Rebuild against latest stable repo (2019-02-07T23:00:00Z) .

dl-button

Full ISO

direct | sig | sha1 | sha256

Minimal ISO

direct | sig | sha1 | sha256


To keep the releases apart I am using yywwd as identifier. That is the year, week of year, day of week.

So 19055 is created on day 5 of week 5 of year 2019.

$ echo $(date +%y%U%w)
19055

Rumours has I am not giving enough credit to my sources of inspiration - so here it is - again:

  • Bunsenlabs is credited for their scripts.
  • ArchLabs is credited for the idea of using Rofi and Polybar and for rewriting bunsenlab scripts to fit Arch → Manjaro

#2

Hey

download speed is very low, roughly 20kb/s atm. not sure if it’s something on my side because i just performed update and downloaded all packages 6mb/s.


#3

Can be because I just uploaded the images and they have not had time to syncronize to the mirrors.


#4

Hey

I installed it, and it seems like i’m not able to get access to polybar menu when i press M from manjaro in the up left corner nothing happens.
However i am able to change desktops from 1 2 3 4, also package manager icon will open as well. But manjaro menu won’t open ;).
I wish polybar had like right click menu button that lets user customize its look (the way there is on xfce or LXDE like i press right click mouse button and can edit the way panel looks)

Anyways, i think the way this openbox has been designed using polybar and other stuff deserves more attention :).
edit:oh btw i didnt install minimal iso but the other one


#5

That is because it a launcher which launches jgmenu and if you do not have jgmenu installed it won’t work.

You will need to take that with the polybar developers.

It is not a desktop environment but a window manager so there is no one-size-fits-all.

You can give it all the attention you want or deem necessary - just use the Openbox root menu → Preferences → Polybar.


#6

check your locale and set it to en us
jgmenu dont work with some locale
at least it does not work with en in


#7

I didn’t know that :question:


#8
jgmenu
fatal: error setting locale

#9

what is

cat /etc/locale.conf

have you tried the jgmenu_run script?


#10
cat /etc/locale.conf
LANG=en_IN
LC_ADDRESS=en_IN
LC_IDENTIFICATION=en_IN
LC_MEASUREMENT=en_IN
LC_MONETARY=en_IN
LC_NAME=en_IN
LC_NUMERIC=en_IN
LC_PAPER=en_IN
LC_TELEPHONE=en_IN
LC_TIME=en_IN
jgmenu_run 
fatal: error setting locale

#11

In my opinion you are missing .UTF-8 on all your locale settings.

Should be en_IN.UTF-8


#12

no such option in manjaro setting manager
locale setting

export LC_ALL=en_IN.UTF-8
[admin@admin-pc ~]$ cat /etc/locale.conf
LANG=en_IN
LC_ADDRESS=en_IN
LC_IDENTIFICATION=en_IN
LC_MEASUREMENT=en_IN
LC_MONETARY=en_IN
LC_NAME=en_IN
LC_NUMERIC=en_IN
LC_PAPER=en_IN
LC_TELEPHONE=en_IN
LC_TIME=en_IN

#13

Edit your locale.conf as root and append .UTF-8 to the entries which does not have this appended.

Check your /etc/locale.gen file.

Edit the file as root and uncomment the line en_IN.UTF-8 - comment any other you do not want to keep and save the file ( I do recommend keeping the en_US.UTF-8 entry)

sudo nano /etc/locale.gen

Run locale-gen command as root

sudo locale-gen

#14
  1. uncomment the locales in /etc/locale.gen
  2. run locale-gen
  3. edit /etc/locale.conf to match
  4. reboot

#15

still same
using en us locale solves it