Onlyoffice display issue: Occupies half the screen

I’ve installed OnlyOffice suite in my ManjaroKDE from 3 sources so far, and they all have the same display issue.

It happened in all: The snap version, the official repository version, and the AUR version. AUR (en) - onlyoffice-bin.
There’s currently nobody talking about the issue in the AUR site, so I though to open this topic here, in case somebody else finds the same issue, or knows a solution specific to ManjaroKDE.

Hello Manja,

I think, that this might be a problem with the HiDPI scaling since you are using a 1440p Monitor.

Could you please go into System Settings, search for Display and change the resolution to 1920x1080, to see if the problem persists? If so, it isn’t a problem with the HiDPI scaling.

I would try this myself, but unfortunately, I don’t have access to a Monitor with a greater resolution than 1080p.

Best Regards, Julius

P.s. make sure to revert the resolution back to 1440 p afterwards, because stuff like text might appear blurry, if you use a lower resolution.

Thanks Julius!
My display settings are: 2560x1440 (16:9), Global scale: 200%.
I changed it to 1900x1080 and it looked the same, so I reverted.

How about the appimage from the onlyoffice website?

Good try! It was the exact same though.

Maybe the company can help: support@onlyoffice.com

I just found this thread via Qwant search. Perhaps you only need to force the scale to 1 : HiDPI Issue · Issue #217 · ONLYOFFICE/DesktopEditors · GitHub

1 Like

Ahh this IS the root of the problem. The screenshots of the issue shared there are exactly like the one I posted here. It seems to affect high dpi screens. I tried their suggested solution but still didn’t work.

Luckily there’s more similar office suites nowadays. I just liked their spreadsheet app because it’s leaner than libreoffice. Perfect for quickly displaying small .xlsx files that don’t need anything advanced.

I LOVE this forum! :smile:

Onlyoffice has free online editors as well, with free storage, which you can export from in a range of formats.

Unfortunately, I can’t try whether these workarounds do something on my device because onlyoffice doesn’t seem to have a download for arm, but if none of these worked for you, you could try:

  • the online editor https://www.onlyoffice.com/office-suite.aspx like leebut proposed
  • Softmaker FreeOffice
    • This one isn’t open source, but it is still free of charge and it might be simpler to use than libreOffice.
      You might prefer this to the online editor, if you prefer being able to edit your documents offline. It uses the xlsx format for excel sheets and also claims to have good compatability with MS office.
      www.freeoffice.com - Download FreeOffice for Windows, Mac and Linux
  • finally, I would encourage you to have a fresh look at LibreOffice. They recently released LibreOffice 7 which has numerous improvements, including performance. I haven’t tried out the new version yet and the package in Manjaro is still 6.4.5-2, but the package will be upgraded soon and you can use the flatpak of LibreOffice, which is already on 7.0, if you can’t wait. flatpak install flathub org.libreoffice.LibreOffice.

I hope that this might be helpful,
best Regards, Julius

1 Like

I think that any company’s claims of compatibility with MS Office seems to mean that files will open in each software, but it does not always result in files rendering the same in each software.

Thanks for the reminder about Libre Office. I’ll have a look and see how it works out.

1 Like