Only windows boots after dual-boot installation

Hi
I installed Manjaro succesfuly on my ssd/efi hard disk besides windows 10. Trying to reboot, I found out that windows boots as usual. But where is Manjaro…???

https://forum.manjaro.org/search?q=windows%20boots%20after%20dual-boot%20installation%20%20order%3Alatest

1 Like

Thanks. So I tried to press F8 while booting but in the apeared menu there was only one option to choose: ´windows boot manager´… Why that?

Long story…
Use this Tutorial to repair/configure Manjaro EFI option

2 Likes

fastboot in windows is disabled?

Something went wrong and now I cannt boot into the installed Manjaro;

  • With the live CD I booted into manjaro ( grub> search.file /etc/manjaro-release root
    grub> configfile /boot/grub/grub.cfg )
  • In the installed manjaro I followed the above tutorial with the UEFI - additional commands. (there was a wornning apearing in the terminal, it looks that it was a very bad idea to ignore it and reboot the system…)
  • After rebooting, again, only windows booted. With the live CD I come to the installed Grub-menu but Manjaro doesnt boot(errors…)
    :roll_eyes:

What was the warning?

Since it’s a fresh installation, it might be better to re-install and next time follow the tutorial to fix grub UEFI option.
Without an error description it is not possible for anyone to help you, unless out of guessing… :thinking:

OK, thanks, I´m going to reinstall now. In which partition is actually grub installed, in the 100 mb efi or in the following windows -C partition which has the boot flag? i guess the C partition, no?

This is not a proper description for UEFI installations.
During the installation, you need to select the 100MB fat partition as $esp (flag) and mount it at /boot/efi

Hi,
So I installed Manjaro again. The wornning in terminal apears after adding the uefi additional-commands in step 6:

$ sudo efibootmgr -c -d /dev/sdb -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”
efibootmgr: ** Warning ** : Boot0001 has same label manjaro
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0003,0001,0002,0000
Boot0000* Windows Boot Manager
Boot0001* manjaro
Boot0002* UEFI: TSSTcorp CDDVDW SH-216FB
Boot0003* manjaro

It looks like Manjaro was already in the boot menu options.
The warning was just info for same labels (you could give a different label name).
Reboot and if still Manjaro is missing, you may try one of the workarounds.

From multiple installs. OP might want to take a good look at straightening out the partition tables, with the idea being to preclude future problems.

regards

1 Like

That´s weird, Manjaro IS in the boot menu BUT sometimes its booting and sometimes (mostly) not. When not, the boot proccess is ending with a black screen so that I must unplug the pc in order to be able to reboot.

Random errors are not nice.
When you boot fine get some info to help repair properly

inxi -SGopuxx
mhwd -li
cat /var/log/Xorg.0.log
cat /var/log/Xorg.0.log.old
efibootmgr -v

Edit: corrected Xorg-log paths (sorry…)

That’s not weird, it’s expected.

That’s weird, but nothing to do with grub or the issue at hand.
One had reported he/she need the pc (you mean laptop?) to be plugged (the mains?) to boot.
The very opposite of yours. I told him/her the battery could be weak. He/she was not amused.
I don’t know what to tell you or to amuse you.

So here are some info´s:

**inxi -SGopuxx**
System:
  Host: burbon-pc Kernel: 4.14.57-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: N/A wm: xfwm4 dm: lightdm Distro: Manjaro Linux 
Graphics:
  Card-1: Intel HD Graphics 530 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:1912 
  Display: x11 server: N/A driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
  v: 4.5 Mesa 18.1.4 compat-v: 3.0 direct render: Yes 
Partition:
  ID-1: / size: 43.29 GiB used: 5.84 GiB (13.5%) fs: ext4 dev: /dev/sdb5 
  uuid: 87bfd5ad-9bdd-4969-8e80-3713efa8f790 
  ID-2: /boot/efi size: 96.0 MiB used: 24.4 MiB (25.4%) fs: vfat 
  dev: /dev/sdb1 uuid: 9E6F-7B5F 
  ID-3: swap-1 size: 3.49 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb4 
  uuid: 600147e1-e83a-44dc-918c-17be9b53b428 
Unmounted:
  ID-1: /dev/sda1 size: 811.36 GiB fs: ntfs label: Data 
  uuid: BA443BD5443B935D 
  ID-2: /dev/sda2 size: 30.00 GiB fs: ntfs label: Recover 
  uuid: DA3C3DC73C3D9F85 
  ID-3: /dev/sda3 size: 499.0 MiB fs: ntfs label: N/A uuid: CAA86F4EA86F37D9 
  ID-4: /dev/sda4 size: 1024.0 MiB fs: vfat label: PRC_RP uuid: 164C-B0D1 
  ID-5: /dev/sdb2 size: 16.0 MiB fs: <root required> label: N/A uuid: N/A 
  ID-6: /dev/sdb3 size: 68.47 GiB fs: ntfs label: Boot 
  uuid: 08CA6EE7CA6ED10C 

Preformatted text mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
     network-r8168            2016.04.20                true            PCI

Warning: No installed USB configs!

type or paste code herecat var/log/Xorg.0.log
cat: var/log/Xorg.0.log: Datei oder Verzeichnis nicht gefunden
[al@burbon-pc ~]$ cat var/log/Xorg.0.log.old
cat: var/log/Xorg.0.log.old: Datei oder Verzeichnis nicht gefunden
[al@burbon-pc ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0000,0003
Boot0000* Windows Boot Manager	HD(1,GPT,1a80a0f8-7e48-4b4e-be58-7f8c43ae46d1,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...I................
Boot0003* manjaro	HD(1,GPT,1a80a0f8-7e48-4b4e-be58-7f8c43ae46d1,0x800,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)

sudo efibootmgr -o 0003,0000

What is computer make and model?
Asus?

Well, as you see I´m not a computer expert, when I get in trouble (screen freezes or so)I use the keybord/key combination to shut down. in this case it doesnt help, or maybe I just don´t know an alternative to repluging the electricity of the pc…)

sudo efibootmgr -o 0003,0000
ootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0003,0000
Boot0000* Windows Boot Manager
Boot0003* manjaro

Its a medion computer

Made by Lenovo with “medion” own brand? (if you know)