Only dummy sound after hard reset

I have seen a lot of similar problems in different forums and a lot of recurring fixes but until now nothing worked for me.
Me system has a tendency to just freeze and when it does I reset it using the button on the case. After that no matter which kernel I try I cannot audio to work, only dummy output.

inxi -Axza

Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
bus ID: 00:1f.3 chip ID: 8086:a170 
Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
Chip ID: 10de:10f1 
Sound Server: ALSA v: k5.4.72-1-MANJARO 

inxi -SMA

System:    Host: frostfell-manjaro Kernel: 5.4.72-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170-A v: Rev 1.xx serial: <superuser/root required> 
UEFI [Legacy]: American Megatrends v: 1302 date: 11/09/2015 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel 
Server: ALSA v: k5.4.72-1-MANJARO

lsmod | grep snd_hda_intel

snd_hda_intel          53248  9
snd_intel_nhlt         20480  1 snd_hda_intel
snd_hda_codec         159744  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core          102400  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_pcm               143360  5 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
snd                   110592  34 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_timer,snd_pcm,snd_rawmidi

lspci -nnk | grep -A2 Audio

00:1f.3 Audio device [0403]: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller [8086:a170] (rev 31)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8698]
        Kernel driver in use: snd_hda_intel
01:00.1 Audio device [0403]: NVIDIA Corporation GP106 High Definition Audio Controller [10de:10f1] (rev a1)
        Subsystem: ZOTAC International (MCO) Ltd. Device [19da:1438]
        Kernel driver in use: snd_hda_intel

I have tried adding snd_hda_intel.dmic_detect=0 to /etc/default/grub as well as some commands like

systemctl --user restart pulseaudio.service
pulseaudio -k
pactl unload-module module-udev-detect
pactl load-module module-udev-detect
pactl load-module module-alsa-card device_id=1
sudo alsa force-reload

and probably some others which I don’t remember, all without getting sound back.
The last one (sudo alsa force-reload) is often recommended but results in the system complaining that there is no such command as alsa and indeed, when just typing al and pressing tab a bunch of stuff shows up, but not alsa itself.
Usually this issues goes away when I wait some time before turning the PC back on.
I would really like to get my sound back. If you need any additional information please let me know.

1 Like

Don’t do that and please read this:

If you’ve used the very hard reset a lot over the last months your system is probably hosed by now and you’re in for a reinstall, so please read this too:


Thank you for making me aware of this.
I now have the SysRQ kex set up and REISUB works fine.
After some computer use the freeze happened again, this time it seemed to at first be just the game I was playing and the audio repeating ½ of a second over and over again.
Closing the game (shellshock live, but this also happens when playing something elseor nothing at all) revealed that it was dead, so was lutris, the rest seemed to work fine. Then falkon slowed down, firefox wouldn’t start.
I tried restarting pulseaudio with some commands I still had on a stickynote, namely systemctl --user restart pulseaudio.service and as that didn’t seem to work pulseaudio -k, after some time the audio stopped, no output devices.
Restarting didn’t work and resulted in the whole video freezing as well. Luckily I had REISUB set up…
With that I get my audio outputs back, but I can’t have my system crash every ~2 hours so maybe I really need to do a reinstall…
I really don’t want to because this is currently my only system with fully working kmail and youtube-dl was taken down…
So I wonder… is there a chance that this is an issue related to pulseaudio or something that I could reasonably fix or is reinstalling my only chance?

I don’t see how you could do a full file system comparison with all the stuff you’ve installed already…


  • take it as a life lesson not to use hard resets unless utterly unavoidable and use soft resets instead
  • reinstall
  • at the first freeze, post some logs so we can have a look and post some meaningful title like “System froze while playing shellshock” not “System freeze” because no one will look at that.

read this too:


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.