On-board sound no-longer works after a swath of tinkering

I still have audio from my monitors via HDMI, but the only sound I’ve been getting out of my 3.5mm headphone jack is periodic crackling of static. Everything was working fine a few days ago, I think it stopped working following a reboot after I had been playing around with audio loopback solutions.

So, how can I help you, help me? What sort of information do I need to provide to troubleshoot this issue?

Can you explain what tinkering you have done and what you have tried so far to rectify the issue? Some basic information about your system would be helpful. Please read:


First up, system information:

  Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <filter> 
  UEFI-[Legacy]: American Megatrends v: P3.80 date: 09/11/2019 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI 
  driver: nvidia v: 465.31 alternate: nouveau,nvidia_drm bus-ID: 06:00.0 
  Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 06:00.1 chip-ID: 10de:10f1 
  class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 1-2:4 chip-ID: 046d:082d 
  class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.12.9-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.18 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.30 running: yes 

Now for what I’ve done on my PC… In no particular order I have:
• Loaded and unloaded audio modules with pactl. (null-sinks)
• Installed, played with, and uninstalled Jack
• Tried reseting, rebooting, and reinstalling ALSA and pulseaudio.
• Created a blank .asoundrc (Tried a few thing, but its’ ultimately empty now)

Here’s a (slightly pruned) extensive list of the commands I’ve ran… — Hopefully I didn’t forget to prune something personal.