Old, deleted files still coming up when seaching using theApplication Launcher

Evening everyone,

I'm having an issue where old, deleted files are still showing up in search. Below I've gone into a little more detail:

I installed drop box onto my PC so I can WFH and still have access to all my files/ documents, drop box didn't seem to work and since I downloaded it from AUR I assumed it was outdate so I uninstalled it. then after noticing my SSD was 95% full I found a hidden folder called drop box and inside was all my documents from the company drop box. I had already deleted the drop box application by this point so deleted the folder.

However when I use the search function on the Application Launcher its still showing the files from said hidden folder. So far I have tried the below:

  • Restarting PC
  • Clearing search history
    and neither of them have worked.

Some details that might help diagnose the issue:

  • I'm using the KDE Desktop
  • I get the below output when trying to open one of the files:
Unable to run the command specified. The file or folder /home/joe/XXXXXX/XXXXXX/XXXXXX/XXXXXX/XXXXXX/XXXXX.pdf does not exist.
  • Any info I can provide to help get this sorted I will gladly do

Can anyone advise on this?

Have you tried emptying your trash? How did you delete the files?

I have, the folder was actually too big to put into the waste bin and had to be fully deleted as root

If the files are gone, it could just be that they are still in your search index.

When did you delete them?

I had a similar issue a while ago with WINE entries (and other files too!) still showing in the Application Launcher after uninstallation/deletion. However it still remained unresolved. I think it's an old bug that has remained unfixed. I eventually reinstalled manjaro at some point and this issue (of course) disappeared.

1 Like

About an hourish ago

Give the indexer some time to catch-up. If it never does, try purging your baloo index.

I did find some mid 2019 post about the same issue that was unsolved but thought I'd try mu luck asking myself, really dont wanna have to install so if its un-fixable for the time being I'll just ignore it.

Would you tell me how to do that please?

balooctl purge

That being said, don't do it unless you need to because it will rescan and re-index all your files which is IO intensive.

Okay, noted. Thankyou, I'll give it a few days before I do that then :grin:

1 Like

Just a little note to anyone who's having the same issue, running the below command still doesn't fix the issue. It seems like @AndrewHunter said that this an old bug that's not been fixed (yet) so unfortunately the only fix is to reinstall Manjaro.

balooctl purge

If anyone has anything to add to this that might be worth a try please still let me know and I'll give it a go as I really don't wanna have to reinstall Manjaro

try this:

rm -rf ~/.local/share/baloo

Edit
iirc "balooctl disable" will empty the index. Reboot, though.

2 Likes

Thank you, I ran that command and rebooted and boom, no more old files. You legend :grin:

1 Like

Glad it worked for you!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by