Offlineimap throwing error now

Hi all!

I have been using offlineimap successfully for several weeks on my Manjaro laptop.

Today, after a large-ish software update, I’m getting the following error when running offlineimap now:


OfflineIMAP 8.0.0
  Licensed under the GNU GPL v2 or any later version (with an OpenSSL exception)
imaplib2 v3.06, Python v3.9.7, OpenSSL 1.1.1l  24 Aug 2021
ERROR: No module named 'commands'
ERROR: Exceptions occurred during the run!
ERROR: No module named 'commands'

I have both Python versions 2 (2.7.18) and 3 (3.9.7) installed.

I have tried using the offlineimap3 package that is working to support Python3, but I still get the same error.

Is anyone else using offlineimap successfully?
I didn’t seem to need to before, but is there a way to force offlineimap to use Python2?


From the Arch repo, if I understand correctly, then offlineimap 8.0.0 is already the Python 3 version.

Maybe your Python version changed and you could try reinstalling, or the -git version from the AUR.

Thanks. I just re-installed offlineimap and i’m getting the same error :frowning:

And the AUR version?

I couldn’t find anything on regarding offlineimap.


Are you asking for where I’m getting offlineimap from?

I’m sorry for the short messages.

Version 8.0.0 is now using Python 3 instead of 2. From your error message, unfortunately, it’s not really possible to see where it went wrong.
I guess a library has a different version than expected but it doesn’t tell us which and if your version is too old or too new.

Could you try the AUR version?

No worries. I tried the offlineimap3-git from AUR and got the same error when launching offlineimap

I found a reference (that I inadvertently introduced) to a file that was causing the issue.

Sorry for the noise

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.