Odroid N2 + Manjaro ARM 19.10 + KDE

Please supply this information when submitting a bug report.

  • What device are you using?
    odroid n2

  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)
    [nln2@n2 ~]$ screenfetch
    nln2@n2.19.10
    OS: Manjaro-ARM 19.12
    Kernel: aarch64 Linux 4.9.177-2-MANJARO-ARM
    ##### Uptime: 17m
    ####### Packages: Unknown
    ##O#O## Shell: bash 5.0.11
    ####### Disk: 6,7G / 59G (12%)
    ########### CPU: Hardkernel ODROID-N2 @ 6x 1.896GHz
    ############# RAM: 624MiB / 3710MiB
    ###############
    ################
    #################
    #####################
    #####################
    #################

  • When did you last run updates and reboot?
    today 2019.12.07

  • What package contains the bug?
    KDE

  • Describe the bug the best you can. What where you doing when the bug happened?
    The keyboard setting (with the local language) and the boot setting are not save
    I boot with the us keyboard and without the wished automatic session

  • Any workarounds or known fixes?
    unfortunately not

The us keyboard(the screenshot show the wished keyboard)

the auto session is not save

kde info

Try setting the keyboard layout via Manjaro Settings Manager instead.

What boot settings are not saved...

1 Like

Hi,

Thanks for your message, the beast (n2 :slight_smile: ) is up to date, I followed your solutions

  1. I set the keyboard with the Manjaro Settings Manager, I rebooted, the keyboard setting is not save and stay tuned with Shakespeare and not Moliere... no problem with my desktop computer on this side

  2. The wishing boot setting is the automatically log in as user (for the n2), the setting is not save, it does not appear saved on the page setting, I rebooted, the log in is not automatic, I have to log in.

(the login page have no virtual keyboard, an improvement idea for kde, manjaro, CoreApps...)

I tested the second point on my desktop computer, same issue, the setting is not save, it does not appear saved on the page setting, I rebooted, BUT the log in is automatic, I don't have to log in, strange...

I have to report this bug to kde ?

Try this:

Keyboard:

sudo localectl set-x11-keymap fr

Autologin:

sudo nano /etc/sddm.conf
 
# At this line put in your user-name after User=
  
# Username for autologin session
User=

Do a Ctrl-X then type the letter y to exit and save

sudo reboot

1 Like

Hi,

Thanks for your reply.

the auto login is now working, but not the keyboard, I tried some other solutions without success.

I'll try this week-end to build a new image (19.12) the actual os is based on the 19.10

There is probably some where in your home directory a keyboard config has been written by that program you used. The command above should have written a global keyboard system keyboard config and something in your home directory is overriding it.

Hi,

I created a 19.12 image for the n2, it doesn't boot, black screen on boot....

So, I installed the 19.10 image, up to date it, is working with the wished keyboard and I added those lines to the sddm.conf file in the beginning for the auto login

[Autologin]
Relogin=false
Session=plasma
User=nln2
...

Corekeyboard is installed and have no effect on the config keyboard.

[nln2@n2 ~]$ screenfetch
nln2@n2.19.10
OS: Manjaro-ARM 19.12
Kernel: aarch64 Linux 4.9.177-2-MANJARO-ARM
##### Uptime: 3m
####### Packages: Unknown
##O#O## Shell: bash 5.0.11
####### Resolution: 1920x1080
########### DE: KDE 5.64.0 / Plasma 5.17.4
############# WM: KWin
############### GTK Theme: Matcha-light-azul [GTK2/3]
################ Icon Theme: Papirus-Dark-Maia
################# Disk: 6,1G / 59G (11%)
##################### CPU: Hardkernel ODROID-N2 @ 6x 1.896GHz
##################### RAM: 548MiB / 3710MiB
#################

Forum kindly sponsored by