odd black border around Firefox window

I have just finished setting up my Plasma desktop. All seems well with one minor exception. I have a weird black border around the Firefox window and only the Firefox window. It looks like it is trying to draw the window shadows and failing? Two questions!
Screenshot_20200117_133528

  • What am I doing wrong?
  • I cannot figure out how to turn off window shadows

It's not a shadow, but an artifact of the fact that Firefox is partly based upon GTK. I had a similar problem here with another GTK application, and I got rid of it by choosing a different theme for GTK in the System Settings. I've installed the Mojave Dark GTK theme from the AUR.

If you want to turn of shadows as a whole, then you'll have to either disable compositing ─ which means that you also won't have any other effects anymore, like translucency, wobbly windows, et al ─ or you'll have to install a window decoration that doesn't have shadows. You'll find plenty of them at store.kde.org.

In order to disable compositing... :arrow_lower_left:

System SettingsHardware → Display and Monitor → Compositor

In order to change the GTK theme... :arrow_lower_left:

System SettingsAppearance → Application Style → GNOME/GTK Application Style

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by