Odd behaviour with the System Tray after installing AUR Nomachine

I’m not sure if this is the cause, but this happened the reboot after installing Nomachine.

For most taskbar icon’s that are not preinstalled on Manjaro (chat programs etc.) the icon’s aren’t corrosponding to the system theme (if they did previously), and left clicking does the same as right clicking, instead of opening like normal.

The programs this specifically effects are: Discord, Caprine, Keybase, Onboard and Solaar.

It does not effect: SVP4Linux, Yakuake, Telegram, and system icons (clipboard, volume, bluetooth, networking)

Discord specifically has the additional problem of not showing it’s icon - it is present in the first few seconds of loading my desktop, and dissapears when it has finished loading. The same thing happens for programs that used to follow the system theme (being normal initially).

I have tried uninstalling Nomachine, and reinstalling kde-plasma, neither have worked.

The only other thing I can think of is, before installing Nomachine via AUR, I tried manually installing it as the site instructed before realizing it wouldn’t run on Manjaro, so I then removed the files before using the AUR installation.

  • remove the AUR install again with:

    pamac remove --no-save nomachine*

    (as --no-save will delete all config files as well)

  • find all nomachine files that might still be lurking around

    sudo find /  -iname *nomachine* 
  • Delete those as well (including their directories)

  • reinstall from the AUR again:

    pamac install nomachine


P.S. If you installed the client only, obviously use nomachine-enterprise-client for the pamac commands, but not for the deletes…

I’ve removed all traces of nomachine like you said and rebooted (haven’t reinstalled yet) - but the issue is still there, it may be a coincidence that this happened after the nomachine installation after all.

Does this problem also occur if your create a new user and log in there?


Just tested now on a test user - still the same behaviour.

One thing to note is if I manually open a relevant program the behaviour changes - it loads the correct icon (even in discords case), and in onboards case it does the normal left click action while still bringing up the right click menu.

I’m sorry, I’ve reached the end of my knowledge (especially since I don’t run nomachine nor discord) so I can’t help you any further…


That’s all good, thanks for your time in any case.

I don’t even know if the behaviour is due to nomachine or a coincidence so I might need to test things in a virtual machine.

1 Like

Just tested installing Onboard (a program that has this issue), restarting, then aur installing nomachine, and doing another restart.
That didn’t reproduce the issue for me so there may have been another cause, I can’t see how failing to install it manually would cause the issue but I’ll try that next.