Octopi-notifier is not working

octopi
kde

#1

I noticed recently that my Octopi-notifier seems not working anymore. It does not check the available updates at all. It is set to ‘480’ minutes right now. I tried with other settings as well, but it does not check the updates because it does not notify me. I have to right click to it and select check updates.

Do you have any ideas what is the reason of this and how it can be solved?
Thanks!


#2

Can confirm and wonder why none others have chimed in?
This has been broken quite awhile as remember mentioning it before. And wonder when a fix is coming?
Only time it pops up in the tray saying I have updates is after I run Octopi and sync. Then pops up in the tray.

Otherwise sits hidden in the tray like a dead Octopi.

As worked fine in KDE Neon & Antergos versions.


#3

I don’t have any problem with my octopi notifier.


#4

Thanks for confirming it. I searched the bugs on github and found this:


Not sure what to do next.


#5

Ahh as the dev states

Manjaro has the bad habit of packaging dev versions as stable ones. So they created that 0.8.3 version which is not oficial as it has never been released. Maybe You should try the upstream code. I’m sorry for that annoyance.

Tho I don’t know if Manjaro team can resolve this? As doesn’t appear to be a affecting everyone?
As running KDE Plasma with default open drivers myself.


#6

did you try to delete the config file?
.config/octopi/octopi.conf


#7

Isn’t that for Octopi and not octopi-notifier?


#8

both use it to save their settings.


#9

my desktop has the same bug, but my “newly” setup notebook (3 weeks ago) shows the updates at startup like intended, will try to remove the config on my desktop and check with the next updates


#10

Yep did that and guess I have to wait for next update to verify it works.
Only question is default is set to “once a day” which doesn’t tell me when that is?
If it checks for updates on startup? which is fine for me when I boot up in the morning.


#11

I did not check the source. but once a day I guess it’s every 24h.
I saw that it save the last time sync in the config file. so I guess if at boot it’s more than 24h since the last sync it will sync.
but I don’t know as I say I did not check the source… maybe it will sync every time the notifier is started (that mean at boot) whatever the settings say…


#12

well, already had updates. Did not work for me.
My notebook notifies me on every update directly at boot, be it in the repo’s or in AUR, - but my desktop does not. The desktop only notifies when I do pacman -Syu in terminal


#13

I deleted the config file and I am on unstable since days. The notifier did not showed updates but after manually sync it did. So the issue seems valid.


#14

[Stable Update] 2016-12-23 - Kernels, Nvidia, Firefox and octopi-notifier running.

And now Christmas eve and no tray notifications. Who do we contact to resolve the issue?
It is a main Manjaro choice included by default. Or the individual that wrote the code?

Package Details: octopi-notifier-frameworks 0.8.5-2

ImNtReal commented on 2016-10-21 20:37

After speaking with the developer, I have decided to stop following the Manjaro releases. Please, do not mark the package out of date because of a new Manjaro package.

kikadf commented on 2016-10-21 17:01

No, the developer working for the new features, check the changelog.txt history. He will tagging a release, if the features will be enough stable for a release. Now we use the instable git source as stable… If devs of Manjaro know better than dev of octopi, they should fork octopi, not make FAKE octopi releases…

ImNtReal commented on 2016-10-21 16:24Because the developer seems to have stopped tagging releases. This is based on the commit Manjaro uses for their 0.8.5 release.

kikadf commented on 2016-10-21 16:08
Don’t understand, why do you build instable git version as stable release?
Use octopi-git and alpm-octopi-utils-git pkgnames instead of FAKE pkgver…

And wondering what this is all about? Between devs of Octopi and Manjaro dev’s?


#15

I think I found what causes the issue.
In /.config/octopi/octopi.conf I had

SyncDbHour=-1
SyncDbInterval=480

I want to use the 8hours sync (8h*60=480 minutes). I found the -1 value suspicious, so after I removed SyncDbHour=-1 line from the file, the auto sync is working.

I think there may be an issue when a user sets the hour sync to hour based sync (SyncDBHour) to Interval based (SyncDbInterval), then the SyncDBHour is not removed from the file.

You can quickly check if the notifier is working or not. Set the sync interval (SyncDbInterval=5) then the octopi.conf should be changed in every 5 minutes because it updates “the last sync time” in the file. (check it in dolphin/krusader, the access date updates in every 5 minutes).

I hope this solves the issue for the others as well :slight_smile:


Octopi not refreshing mirrors (and/or finding package updates)
[Stable Update] 2018-07-01 - Kernels, KDE, LibreOffice, Browsers, Mesa, Systemd, Deepin
#16

octopi check first if SyncDbInterval is not -1 than mean it use once a day or at a specific time.
then if SyncDbHour >= 0 that mean at a specific time. and if both = -1 that mean once a day. but it first check interval. so if interval is not -1, it don’t care about SyncDbHour

  if (syncDbInterval == -1)
  {
    if (syncHour >= 0) //Once a day at a certain time?
    {
      if (m_debugInfo)
        qDebug() << "SyncDb is scheduled once a day, at " << syncHour << " hours";

      if (lastCheckTime.daysTo(now) >= 1 && now.time().hour() == syncHour)
      {
        syncTime = true;
      }
    }
    else
    {
      if (m_debugInfo)
        qDebug() << "SyncDb is scheduled once a day";
    }

    if ((syncHour == -1 && (
           lastCheckTime.isNull() ||
           lastCheckTime.daysTo(now) >= 1)) || (syncTime))
    {
      syncDatabase();
      //Then we set new LastCheckTime...
      SettingsManager::setLastSyncDbTime(now);
    }
  }
  else
  {
    if (lastCheckTime.isNull() || now.addSecs(-(syncDbInterval * 60)) >= lastCheckTime)
    {
      syncDatabase();
      //Then we set new LastCheckTime...
      SettingsManager::setLastSyncDbTime(now);
    }
    else
    {
      if (m_debugInfo)
        qDebug() << "SyncDb is scheduled once every " << syncDbInterval << " minutes.";
    }

    m_pacmanHelperTimer->stop();
    m_pacmanHelperTimer->start();
}

#17

Good to know. Anyway, I changed to config file from another computer where it was working, and it did not contain the SyncDbHour=-1, so I thought that is the root cause of the failure.
In case the issue still exist, try deleting the config file, restart, setup the interval and it should work I think.


#18

by default it does not. but I never had any problem with interval sync and to have SyncDbHour set.