octopi can't upgrade system

When I try upgrade my system I get a conflict whit the package mesa-git, its an older build. new mesa-git wont build because it need new llvm which is in the update I can't install..
when I try to remove mesa-git it "would like to remove 999 dependence".

I can't build mesa-git and I can't remove it
I can't upgrade my system to be able to build mesa-git
I can't install normal arch mesa package

Can you please post the errors you get when installing llvm?

when upgrading only llvm with octopi

sudo /usr/lib/octopi/octphelper -ts
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-llvm-libs (9.0.1-1) breaks dependency 'lib32-llvm-libs=9.0.0' required by lib32-mesa-git
:: installing llvm-libs (9.0.1-1) breaks dependency 'llvm-libs=9.0.0' required by mesa-git
Press any key to continue...

Have you tried running the update in normal pacman?

sudo pacman -Syu

If that doesn't work, try

sudo pacman -Syu mesa lib32-mesa

If it asks you to remove mesa-git, select yes.

1 Like

that work thank you :smiley:

Marking @ben81's post as the solution to the OP's update issue.

there is a little aftermath question here
in aur I have xf86-input-mouse and xf86-input-keyboard leftovers from mesa-git
should I keep them? why are they in aur?

A search in the forum for xf86-input-mouse :
50+ results for xf86-input-mouse

Looks as if those packages have been dropped from Manjaro's repo. So I guess if nothing else is dependent on them, they could be removed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by