OBS-studio 27.0.1-2 no longer showing virtual camera after update to 21.1 and kernel 5.14.x

First let my start by saying that obs and virtual camera (webcam) was working as expected before I updated.

I have completely uninstalled obs-studio and v4l2loopback-kdms including any .config and *rc files.
then reinstalled it.

but it’s still not working. I do not see the “Start virtual camera” button anymore.
When I go to add my webcam under the video capture device (v4l2) it sees my Depstech webcam but does not show the video feed.

I can start the camera and video feed if I use qt v4l2 test utility, so Manjaro must see and recognize it

I reinstalled obs and v4l2loopback using pamac.

I found this tutorial on the forum here but it seems to be old, I have not tried it yet.
the reason I have not tried it is, I’m not sure if I can delete the git clone directories when it’s done?

Does anybody have the same problem?

1 Like

Please read this:

Especially the Linux has multiple kernels section, then try an LTS kernel and hopefully the problem will go away “automagically”. :grin:


1 Like

As you gave me a :heart: : did the issue go away?


Still don’t see the output from the camera. But I got the virtual camera button back by reinstalling obs from pamac. But I loved that tread you liked to that will be my new reading material for a while. Henson the heart. I’m gonna open a new tread and find out what “webcams” people are using.

Thank you very much for your help:)

My solution was to:

pacman remove --no-save obs-studio 
pacman remove --no-save v4l2loopback-dkms 
sudo updatedb 
locate obs-studio 

Then use the rm --recursive --force --verbose command to remove all files leftover from OBS-studio.

Then reinstall OBS-studio, v4l2loopback-dkms, obs-v4l2sink, using pamac:

sudo pamac install obs-studio

(when prompted install v4l2loopback-dkms as well.)

sudo pamac install obs-v4l2sink

reboot your system and open obs-studio you should now have a new menu option under the Tools section called v4l2sink.

You might have to use this command:

sudo modprobe v4l2loopback

to get the start virtual camera button to show.

Source for solution

1 Like

will do, thank you for your help Fabby!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.