Nvidia rtx overclocking

I'm trying to overclock my rtx 2060 gpu but for some reason coolbits doesn't seem stay set at 8 because when i rebboot after doing
sudo nvidia-xconfig --cool-bits=8
Help would be much appreciated

because the default directory nvidia-xconfig uses is /etc/X11/ and the configuration file thats read by xorg is in /etc/X11/xorg.conf.d

post output of:

inxi -Fxxxz
ls -laR /etc/X11
cat /etc/X11/xorg.conf.d/*.conf

use the </> button above the post entry box when posting terminal output so it's formatted properly and not a mess.

inxi -Fxxxz
System:    Host: Xerneas Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           tk: Qt 5.12.3 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: X370 SLI PLUS (MS-7A33) v: 2.0 serial: <filter> UEFI: American Megatrends v: 3.E0 
           date: 09/25/2018 
CPU:       Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 93629 
           Speed: 3131 MHz min/max: N/A Core speeds (MHz): 1: 3131 2: 3145 3: 3120 4: 3123 5: 3137 6: 3147 7: 3129 8: 3122 
           9: 3378 10: 3817 11: 3143 12: 3123 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: eVga.com. driver: nvidia v: 430.14 bus ID: 29:00.0 
           chip ID: 10de:1f08 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 29:00.1 
           chip ID: 10de:10f9 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 2b:00.3 chip ID: 1022:1457 
           Device-3: Roland type: USB driver: snd-usb-audio bus ID: 1-12:2 chip ID: 0582:01e0 
           Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.047.01-NAPI port: f000 bus ID: 21:00.0 chip ID: 10ec:8168 
           IF: enp33s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k v: kernel port: f000 bus ID: 26:00.0 
           chip ID: 168c:0030 
           IF: wlp38s0 state: up mac: <filter> 
Drives:    Local Storage: total: 2.77 TiB used: 1.74 TiB (62.9%) 
           ID-1: /dev/sda vendor: A-Data model: SU800 size: 953.87 GiB speed: 6.0 Gb/s serial: <filter> rev: 7ANR scheme: GPT 
           ID-2: /dev/sdb vendor: A-Data model: SU800 size: 953.87 GiB speed: 6.0 Gb/s serial: <filter> rev: 7ANR scheme: GPT 
           ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB speed: 6.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: CC49 scheme: GPT 
Partition: ID-1: / size: 937.60 GiB used: 362.06 GiB (38.6%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 38.2 C mobo: N/A gpu: nvidia temp: 52 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 275 Uptime: 1h 35m Memory: 15.67 GiB used: 2.01 GiB (12.8%) Init: systemd v: 242 Compilers: gcc: 8.3.0 
           Shell: bash v: 5.0.7 running in: konsole inxi: 3.0.34 


ls -laR /etc/X11
/etc/X11:
total 40
drwxr-xr-x  5 root root 4096 Jun 25 13:58 .
drwxr-xr-x 88 root root 4096 Jun 25 14:24 ..
drwxr-xr-x  2 root root 4096 Jun 15 19:19 mhwd.d
drwxr-xr-x  3 root root 4096 Mar 12 05:40 xinit
-rw-r--r--  1 root root 1230 Jun 25 13:58 xorg.conf
-rw-r--r--  1 root root 1230 Jun 25 13:58 xorg.conf.backup
drwxr-xr-x  2 root root 4096 Jun 15 19:19 xorg.conf.d
-rw-r--r--  1 root root    0 Jun 25 13:45 xorg.conf.nvidia-xconfig-original

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 Jun 15 19:19 .
drwxr-xr-x 5 root root 4096 Jun 25 13:58 ..
-rw-r--r-- 1 root root 1522 Jun 15 19:19 nvidia.conf
-rw-r--r-- 1 root root    0 Jun 15 19:19 nvidia.conf.nvidia-xconfig-original

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Mar 12 05:40 .
drwxr-xr-x 5 root root 4096 Jun 25 13:58 ..
-rw-r--r-- 1 root root  739 Mar  4 13:31 xinitrc
drwxr-xr-x 2 root root 4096 Jun 16 00:10 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4 13:31 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Jun 16 00:10 .
drwxr-xr-x 3 root root 4096 Mar 12 05:40 ..
-rwxr-xr-x 1 root root  318 Nov  9  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 May 11 07:13 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 16
drwxr-xr-x 2 root root 4096 Jun 15 19:19 .
drwxr-xr-x 5 root root 4096 Jun 25 13:58 ..
-rw-r--r-- 1 root root  266 Jun 15 19:19 00-keyboard.conf
lrwxrwxrwx 1 root root   27 Jun 15 19:19 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf



cat /etc/X11/xorg.conf.d/*.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 418.43

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
        Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

ok, from terminal

sudo nvidia-xconfig -c /etc/X11/mhwd.d/nvidia.conf -o /etc/X11/mhwd.d/nvidia.conf --cool-bits=8
#then post
cat /etc/X11/mhwd.d/nvidia.conf

and coolbits should be set in the config

also, if your using GWE to do the overclocking make sure you dont set it to start on boot, if you accidentally enter a value that causes the gpu to crash it will load that value when you boot and so causing the crash during boot each time. make sure it's a stable value before commiting it to be persistent. i use the nvidia settings to do it when needed so it's not active all the time.

cat /etc/X11/mhwd.d/nvidia.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.14


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputClass"
    Identifier         "Keyboard Defaults"
    MatchIsKeyboard    "yes"
    Option         "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "1"
    Option         "Coolbits" "8"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

1 Like

coolbits is set, reboot and it should be all set

works thx

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by