Nvidia render offloading

it's likely due to a conflicting configuration, or conflicting with optimus-manager.

you need to disable optimus-manager and run it's cleanup script.

systemctl disable optimus-manager --now
optimus-manager --cleanup

and uninstall it. and uninstall bumblebee if it's installed as well via mhwd. for this setup to work you should have only video-nvidia installed.

if any of the configurations are left behind in these directories, they will conflict with the render offload configurations
/etc/X11/xorg.conf.d
/etc/modprobe.d/
/etc/modules-load.d/

Much appreciation for the fast reply. I had not run optimus-manager's cleanup (I knew about it, but I was following the OP strictly). Will do that, and I will switch to video-nvidia, then try again.

bumblebeed is already disabled, so that shouldn't be interfering in any case, but I will get it uninstalled explicitly.

1 Like

you should still get rid of it, even with it disabled the bbswitch packages remain installed and they can be problematic. uninstall bumblebee and install video-nvidia is a good idea

Yep, I removed the MHWD config with mhwd -r pci <long bumblebee package name> and saw it get removed. Then I installed video-nvidia. I'm getting closer:

 ~  env __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor                 15:06:24
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
 ~  glxinfo | grep vendor                                                                          128ms  15:06:30
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: Intel Open Source Technology Center

I'm still not sure how to tell it to use the dGPU to power my external monitor. It seems I have offloading configured, but the moniitor's still black.

(As an aside, looks like Turing cards really can be turned off, if I am reading this output correctly:

 ~  nvidia-smi                                                                                     125ms  15:08:43
Sun Aug 18 15:08:44 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 435.17       Driver Version: 435.17       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce RTX 208...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   48C    P8     3W /  N/A |     17MiB /  7982MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1006      G   /usr/lib/Xorg                                 15MiB |
+-----------------------------------------------------------------------------+

)

Uninstall everything all mhwd configs first. Via mhwd, of course. Then install only linux52-nvidia (where 52 is the version of your current kernel). You might also want to install xf86-video-intel. Also make sure to disable nouveau cuz it often interferes reboot process. It can be done with complete disable like adding modprobe.blacklist=nouveau to bootloader's kernel options, or nouveau.modeset=0 to disable modesetting of nouveau driver, or nouveau.noaccel=1 (the most non-intrusive way). Check your /etc/mkinitcpio.conf MODULES section for the presence ofi915. Regenerate initramfs withsudo mkinitcpio -p linux52` (where 52 is your linux version).
Now you are ready to copypaste OP's xorg conf and reboot.

ATTENTION! CRITICAL ERROR! YOUR PC IS GOING TO BURST!
I'm kidding just REMOVE IT.

no, dont remove it. and mhwd does all that blacklisting for you. besides he has it working

OK, did this.

Added i915 to MODULES section in /etc/mkinitcpio.conf.

Added modprobe.blacklist=nouveau to GRUB_CMDLINE_LINUX_DEFAULT as written on the Arch wiki re. how to set kernel parameters. Regenerated initramfs (it built fine).

Attempting reboot now.

Yeah that partially was a joke but. Since we're early adopters we should first set this thing properly without pre-configured Manjaro settings, which may be the culprit if something goes wrong.

your reading it correctly, it's just not providing the right info. mine also displays 0% when sitting still and it's a 960m

looks like render offload is working like it should be. if you cant get the external monitor working you should start a separate thread about it so this one is not hijacked anymore than it already is (im guilty of this as well)

@openminded OK, gonna break this out into a separate thread then.

1 Like

add not being able to use "CoolBits" whatsoever, to the list with render offload. tried, failed, then read this
https://devtalk.nvidia.com/default/topic/1061165/cannot-enable-coolbits-with-prime-render-offload/

Forum kindly sponsored by Bytemark