Nvidia proprietary drivers not installable

You have both the i915 and nouveau kernel modules loaded, so video-linux is defaulting to an intel-nouveau-prime setup.

If you have both video-linux and video-nvidia installed that could be causing a conflict, but that technically shouldn’t be causing system freezing.

i had a very similar if not exact experience last week when i tried installing kde on my optimus laptop and for some reason just like said, any attempt to do anything with mhwd would result in lockup , after a few hours i gave up because i have gnome on my other drive and i was frustrated, i dont usually give in that easy. my only afterthough was to just chroot in from my gnome or a live desktop and see if it would allow me to do what i wanted to do which was set it up for PRIME which is the only thing that ever seemed to work for me.
follow the tutorial that @sueridgepipe mentioned regarding PRIME, best of luck

1 Like

the strangest part of it was that KDE installed and actually load the desktop environment whereas every other DE (gnome,deepin,budgie,xfce) would only make it to login and then go to black screen and i would have to chroot in and mess around and finally after days i got it working with prime. the point im trying to make is for some reason kde was behaving differently than the other DE’s . got me pretty excited until i tried to do anything involving video settings or mhwd.
hope you get it worked out, im looking forward to seeing how it goes.

I’m gonna write this as I go, so might be a bit funny reading.
I chrooted into my system trough a liveboot, but the mhwd commands tell me I have no PCI nor USB devices nor configs. Could it be because I have to put the systemd.mask=mhwd-live.service in to be able to boot the live USB? Gonna try the architect image, as that one didn’t need that setting.

Chrooting on Architect gives me the same warning messages that there are no devices or configs found. I guess it didn’t matter that much which one I used. Gonna try to just install and do the next steps and see where it leads me.

installing video-nvidia gives success message. It now shows when trying to list it with mhwd -li

followed the rest of that tutorial for PRIME, reboot

Laptop now goes on till Started TLP system startup/shutdown, like before. However, this time it doesn’t completely lock anymore. Before that little underscore would stop blinking and the fans on my laptop would start running 100%, whereas they are now both going on normally. Just the OS is not continuing. I’m going to check if I didn’t make any spelling mistakes anywhere, or something like that. In the mean time, any ideas?

[OK] Started Login Service.
[OK] Reacher target Multi-User System.
     Starting TLP system startup/shutdown...
[OK] Started Simple Desktop Display Manager.
[OK] Reached target Graphical Interface.
     Starting WPA supplicant...
[OK] Started WPA supplicant.
[OK] Started TLP system startup/shutdown

Deleted my other comment because it was this one but I accidentally pressed enter halfway.

You can always edit any of your previous posts. It’s a “modern” forum engine!! :grin:

I know, but I still needed to write half of it and due to me typing on a system that works next to my laptop that doesn’t work yet I have to carefully type over from the other screen. I didn’t want someone to see a half comment because I wasn’t finished yet, so I “edited” to get back what I had including formatting, put it in a new comment and deleted the first :wink:

It was more a notion for the curious because the message will be there for another 24 hours and I hope to have it fixed by than anyways.

You may want to have a look at the nvidia manual for 410.73:
Optimus
Common problems
Known issues
Xconfig options

I’ve gotten some further. I was being an idiot and used tabs in the xorg.conf :sweat_smile:
Now on to the next problem. It get’s a bit further but not looks at this when it stops:

[OK] Started Login Service.
     Starting Load/Save RF Kill Switch Status...
[OK] Started Load/Save RF Kill Switch Status.
[OK] Started Network Manager.
[OK] Reached target Network.
     Starting Permit User Sessions...
[OK] Started Permit User Sessions.
[OK] Started Simple Desktop Display Manager.
     Starting Hostname Service...

Then a big gap and continous:

Starting Bluetooth service...
[OK] Started Bluetooth service.
[OK] Started Authorization Manager.
[OK] Started Modem Manager.
[OK] Started Hostname Service.
     Starting Network Manager Script Dispatcher Service...
[OK] Reached target Multi-User System.
[OK] Reached target Graphical Interface.
     Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
[OK] Reached target Bluetooth.
     Starting TLP system startup/shutdown...
[OK] Started Load/Save Screen Backlight Brightness of backlight:intel_backlight...
[OK] Started Network Manager Script Dispatcher Service.
[OK] Reached target Sound Card.
[OK] Started TLP system startup/shutdown.

And then it stops without continuing. Again, it still not crashing on me anymore.

Other than that, I’ve checked all the files according to that tutorial, those should all be well now.
Any one of you an idea why it’s not working yet?

@AgentS I’m reading up on those links in the mean time. Generally I learn my Linux stuff while doing, and never having had such issues before, I’ve learned a lot in the past day already :slight_smile:

Then you should provide your new logs even from TTY, - HowTo :

journalctl -b -p3
journalctl -b -g "NVIDIA|Nvidia|nvidia|NOUVEAU|nouveau"
cat /var/log/Xorg.0.log
mhwd -li

Did you try booting with such kernel parametres: acpi_osi=! acpi_osi='Windows 2015'?

Thanks, I didn’t know I could still get into TTY like that. That’s great!

journalctl -b -p3 returns the next for me:

-- Logs begin at Sun 2018-11-11 05:24:02 CET, end at SUN 2018-11-11 16:50_05 CET. --
nov 11 16:49:33 cambionn-laptop kernel: ACPI BIOS Error (bug): Failure creating [\_SB.PCT0.SATO.PRT0], AE_ALREADY_EXISTS (20180810/dswload2-316)
nov 11 16:49:33 cambionn-laptop kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20180810/psobject-221)
nov 11 16:49:33 cambionn-laptop kernel: ACPI ERROR: Skip parsing opcode Device (20180810/psloop-543)
nov 11 16:49:33 cambionn-laptop systemd-modules-load[252]: Failed to insert 'nvidia': Exec format error
nov 11 16:49:33 cambionn-laptop systemd-udevd[272]: SPecified group 'plugdev' unknown
nov 11 16:49:33 cambionn-laptop systemd-modules-load[252]: Failed to insert 'nvidia_drm': Exec format error
nov 11 16:49:33 cambionn-laptop systemd[1]: Failed to Load Kernel Modules.
nov 11 16:49:33 cambionn-laptop kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/responce buffer. [mem oxfed40000-0xfed4087f flags 0x200] vs fed 40080 f80
nov 11 16:49:34 cambionn-laptop kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/responce buffer. [mem oxfed40000-0xfed4087f flags 0x200] vs fed 40080 f80
nov 11 16:49:34 cambionn-laptop systemd-modules-load[393]: Failed to insert 'nvidia' : Exec format error
nov 11 16:49:34 cambionn-laptop systemd-modules-load[393]: Failed to insert 'nvidia_drm' Exec format error
nov 11 16:49:34 cambionn-laptop systemd[1]: Failed to start Load Kernel Modules.
nov 11 16:49:35 cambionn-laptop systemd-modules-load[548]: Failed to insert 'nvidia': Exec format error
nov 11 16:49:35 cambionn-laptop systemd-modules-load[548]: Failed to insert 'nvidia_drm': Exec format error
nov 11 16:49:35 cambionn-laptop systemd[1]: Failed to start Load Kernel Modules.

then journalctl -b -g "NVIDIA|Nvidia|nvidia|NOUVEAU|nouveau" returns the next

-- Logs begin at Sun 2018-11-11 05:24:02 CET, end at Sun 2018-11-11 17:05:51 CET. --
nov 11 16:49:33 cambionn-laptop systemd-modules-load[252]: Failed to insert 'nvidia': Exec format error
nov 11 16:49:33 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:33 cambionn-laptop systemd-modules-load[252]: Failed to insert 'nvidia_drm': Exec format error
nov 11 16:49:33 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:33 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:33 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:34 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:34 cambionn-laptop systemd-modules-load[393]: Failed to insert 'nvidia': Exec format error
nov 11 16:49:34 cambionn-laptop systemd-modules-load[393]: Failed to insert 'nvidia_drm': Exec format error
nov 11 16:49:34 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout
nov 11 16:49:35 cambionn-laptop systemd-modules-load[548]: Failed to insert 'nvidia': Exec format error
nov 11 16:49:35 cambionn-laptop kernel: nvidia: diagrees about version of symbol module_layout
nov 11 16:49:35 cambionn-laptop systemd-modules-load[548]: Failed to instert 'nvidia_drm': Exec format error
nov 11 16:49:35 cambionn-laptop kernel: nvidia: disagrees about version of symbol module_layout

I’m getting back to you with the cat /var/log/Xorg.0.log output. It’s really long to type over so you gotta give me a sec for that.

mhwd -li returns the following:

>Installed PCI configs:
---------------------------------------------------------------------------------
NAME                      VERSION                          FREEDRIVER                    TYPE
---------------------------------------------------------------------------------
video-nvidia             2018.08.09                        false                                PCI

Warning: No installed USB configs!

within /etc/modprobe.d/nvidia.conf stands the following:

blacklist nouveau
blacklist nvidiafb
blacklist rivafb

within /etc/modprobe.d/nvidia-drm.conf stands:

options nvidia_drm modeset=1

As said previously, I followed the tutorial for using PRIME that @sueridgepipe had linked, beside that I didn’t remove any drivers as according to mhwd -li there where none to be found.

@openminded I did that in the beginning (but then 2009), but I’ve got to admit I’ve forgotten to test that now that stuff is working a little bit more. However, I just tested. Both 2015 and 2009 don’t change a thing.

Have you fully updated your system? I missed it if you said so.

Not my OS, I’m on the stock version of Manjaro 18.0 KDE. After hadding done multiple re-installs yesterday I was a bit done with it and figured I want to make stuff work first as I kept updating my OS and such. There where 76 packages not up to date last time I did get into the OS.

Funny enough, for some reason I had to manually update the pacman-key thing, it didn’t do well automatically during update, even trough I think I saw it trying to go trough that in console. Would you recommend me to update with pacman -Syu trough TTY now?

I did make sure my BIOS and such are up to date.

Yes!
Stop whatever you are doing and update your system!

No panic… :expressionless: I am just saying, there are clues, your issues are due to not updated system.

1 Like

Now that you mention updates, that makes sense when it repeating said :sweat_smile:

kernel: nvidia: disagrees about version of symbol module_layout

(although in my defence, I didn’t even get so far to get that log on my own. After a while you think you quite know some, and compared to those around me it might be true, but then when issues like this arise I go back to feeling like a noob compared to you guys :joy::joy::joy:)

It’s updated now. I wasn’t doing much more useful than writing the important part of that last log for you. I already spend around 17 or so hours trying to figure stuff out myself before I came to ask. I know my limits, unless I know what I’m doing with it and realise something (or find something) thanks to said help, I’m not going to play too much around while getting help. I know how much I dislike it when I help people at work and they change tons of stuff themselves trying to fix it making stuff more often only more complex. I don’t want to accidentally make it worse.

Like I said, I updated in the beginning, but after a while I was so done with reinstalling, I wanted to make some steps forward first. Anyways, after updating I’m in my system again.
And it seems like stuff is working.

$ glxinfo | grep -i vendor
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Thank you guys so much! All of you who helped me out passed two days! Learned a lot. Never had issues with video drivers nor the default installations before (I tend to just break stuff myself), so lot of new stuff. Now I’ve got one evening to set stuff up for work, but that’s the easy part ^^.

Quick question, can I select multiple replies to solve my problem? Because it was a combo of things really. Or is it best to just select last/more explicit, etc? Then I trow this questions into solved and close it :slight_smile:

No, only one. I guess it was Rule No1. After first boot, update your system first.

Well, the original issue was getting the drivers to work, which required me to chroot into the system (which is the part I didn’t think about myself as I tried installing PRIME but had crashes) from life boot and manually install the PRIME stuff.

But yeah, defiantly always keep stuff updated. I swear I normally do and just neglected it because I had reinstalled the damn thing between 10-15 times trying different things. After around the 7th time I decided to first try to get stuff running and THEN update, then forgot until you mentioned it :sweat_smile:

Ah well, @sueridgepipe made me know what to do with the drivers, @dglt made me realise how to work around something to get that done, and you @AgentS made me fix the last part which was pretty much my own stupid fault. I’ll just link this one crediting all of you as solution, I think that’s the most easy to see for others who look up and have the same issue.

2 Likes

hey, glad to see you got it working, i think i’ll give kde another shot

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by