NVIDIA proprietary drivers cause "input not supported"

I have an NVIDIA 960 and have been trying to install Manjaro 6.1.12 on my computer with proprietary drivers. Unfortunately when I boot from USB with proprietary drivers all I see is “Input not supported” on my monitor. This also occurred after I tried to install proprietary drivers on a installation with open source ones and restarted the system. Huge bummer since I want to play games on this computer. Any advice you could offer is appreciated. Im very new to linux, so I may need more explanation than other folks on this forum.

Again, Thank you

Hello @gage :wink:

What version? What is the exact model?

Please open terminal and enter:

inxi -v7az

That will print detailed system information.

Please don’t send pictures, instead copy and paste the output here as code. Markdown is supported :wink:

Also, this should be useful:

mhwd -l
mhwd -li

hey @megavolt , thank you for your reply. Here is the information from the inxi command

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=db1347e3-f110-4776-a425-dae9e0192e3b rw quiet splash
    resume=UUID=c5494d64-bf36-4c2e-acfb-981e2c0da07a udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: MSI product: MS-7823 v: 1.0
    serial: <superuser required>
  Mobo: MSI model: CSM-H87M-G43 (MS-7823) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.4
    date: 09/23/2013
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 13.59 GiB used: 4.24 GiB (31.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1834 high: 3900 min/max: 800/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 857 3: 1080
    4: 800 5: 1409 6: 3900 7: 1933 8: 3900 bogomips: 54420
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: eVga.com. driver: nouveau
    v: kernel non-free: 525.xx+ status: current (as of 2023-02) arch: Maxwell
    code: GMxxx process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: HDMI-A-1
    empty: DP-1, DP-2, DP-3, DVI-I-1 bus-ID: 01:00.0 chip-ID: 10de:1401
    class-ID: 0300 temp: 26.0 C
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer K273 serial: <filter>
    built: 2022 res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.3 Mesa 22.3.5 renderer: NV126 direct-render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-2: NVIDIA GM206 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fba
    class-ID: 0403
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 728.46 GiB used: 78.05 GiB (10.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000AAKX-60U6AA0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1H18 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Cruzer Glide
    size: 29.82 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.27 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Optical-1: /dev/sr0 vendor: ASUS model: DRW-24F1ST a rev: 1.00
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 217.64 GiB size: 213.17 GiB (97.94%)
    used: 78.05 GiB (36.6%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: db1347e3-f110-4776-a425-dae9e0192e3b
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: N/A
    uuid: 152D-E28E
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 14.94 GiB used: 512 KiB (0.0%)
    priority: -2 dev: /dev/sdb3 maj-min: 8:19 label: swap
    uuid: c5494d64-bf36-4c2e-acfb-981e2c0da07a
  ID-1: /dev/sda1 maj-min: 8:1 size: 465.76 GiB fs: ntfs label: New Volume
    uuid: 94E63CE8E63CCBEC
  ID-2: /dev/sdc1 maj-min: 8:33 size: 3.31 GiB fs: iso9660
  ID-3: /dev/sdc2 maj-min: 8:34 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: 7CFD-039F
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-6: 3-3:3 info: Dell Keyboard Hub ports: 3 rev: 1.1 speed: 12 Mb/s
    power: 50mA chip-ID: 413c:1001 class-ID: 0900
  Device-1: 3-3.1:5 info: Dell Keyboard HID Support type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 50mA
    chip-ID: 413c:2001 class-ID: 0300
  Device-2: 3-11:4 info: SanDisk Cruzer Glide type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 0781:5575 class-ID: 0806 serial: <filter>
  Hub-7: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 92.0 C mobo: N/A gpu: nouveau temp: 26.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 661
  Processes: 255 Uptime: 1h 14m wakeups: 6 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1090 libs: 331 tools: pamac Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25

mhwd -li gives

                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

mhwd -l gives

                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
    video-nvidia-390xx            2021.11.26               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

@gage So actually you are running the nouveau driver. , but nvidia driver is installed, but not loaded. I guess you just installed the driver with the package manager and not with mhwd?

Did you follow this guide, or how did you install it?

While trouble shooting this i installed a package called nvidia-utils. would that have installed it?

is there a specific one is should be loading into and how would I do that?

Mhwd can autodetect the gpu and install the correct driver:

 sudo mhwd -a pci nonfree 0300 

It also does all basic configurations for the nvidia driver.

Last time I ran that command and restarted my pc it said “input not supported”. I shoulve specified thats how i installed it thats my bad.

I guess the resolution which was detected by the nvidia driver was not supported by the monitor, therefore the monitor reports “Input not supported”.

Maybe try the 470xx driver instead:

sudo mhwd -i video-nvidia-470xx

before fiddling with custom EDID’s.

After a restart it still is using open source drivers. mhwd -li shoes both video-linux and video-nvida-470xx. inxi gives

Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: eVga.com. driver: nvidia
    v: 470.161.03 alternate: nouveau,nvidia_drm non-free: 525.xx+

It seems like the proprietary driver isn’t working and its going to the backup?



Do you see the difference? Actually, you are running the NVIDIA driver now.

Dang, the game im trying to play isn’t working even with the nvidia driver then. When i launch the game it says A D3D11-compatible GPU (Feature level 11.0, Shader Model 5.0) is required to run the engine. which is weird because this game worked on windows and should work with proton.

Vulkan is needed for DXVK.

Test if vulkan is working:

pamac install vulkan-tools
vulkaninfo --summary

Probably you need to add this to the startup options:

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json %command%
1 Like

Vulkan-info --summary gives

Instance Extensions: count = 20
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_portability_enumeration         : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6

Instance Layers: count = 5
VK_LAYER_NV_optimus               NVIDIA Optimus layer         1.2.175  version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.3.207  version 1

        apiVersion         = 1.2.175
        driverVersion      = 470.161.3.192
        vendorID           = 0x10de
        deviceID           = 0x1401
        deviceType         = PHYSICAL_DEVICE_TYPE_DISCRETE_GPU
        deviceName         = NVIDIA GeForce GTX 960
        driverID           = DRIVER_ID_NVIDIA_PROPRIETARY
        driverName         = NVIDIA
        driverInfo         = 470.161.03
        conformanceVersion =
        deviceUUID         = 1fdb99f3-5271-a6f9-230c-090b18d529f4
        driverUUID         = 21235eef-a066-1931-6351-fce5f4c8e266

and vkcube causes some windows to do a waterfall effect when i move them.

I am not sure what you mean by startup options.

No idea. :man_shrugging:

You said, you use proton, therefore I assume you use steam and steam has startup options, game launch options or however it is called.

unfortunately putting that in the options did not help.

Vulkan works on your system beside this “water fall” effect (what ever that is). It must be then clearly a steam or proton issue. But that is not the topic of this thread. I guess the main problem is solved now?

Feel free to create another topic about steam and the game.

Don’t forget to mark the post which solved your problem as Solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.