Nvidia prime leads to black screen


#1

I spent one week searching everywhere trying to find out how to solve this problem but I came up short, I’m running the latest version of Manjaro KDE 18 on my msi gaming laptop GS63VR 6RF 2016 model with i7 6700HQ and nvidia GTX 1060 graphics, I tried installing bumblebee but the Nvidia X server settings gui app is not detecting my built-in laptop monitor so I ditched bumblebee , I installed Prime using [HowTo] Set up PRIME with NVIDIA proprietary driver but after reboot it reached the point of starting TLP service and system startup/shutdown then it hangs and not going further so what is my option here?


#2

There are some instructions here https://wiki.archlinux.org/index.php/MSI_GS63VR#Nvidia/Optimus on getting this model working with bumblebee if that is your preference.

Otherwise you will need to chroot in (see Can't login - black screen & chroot guide) from an live session (installation media) and look for errors in the logs. Start with sudo journalctl -p3.


#3

thanks I already tried bumblebee with those boot parameters, but like I said its not detecting my builtin monitor.
But i will chroot into the system and get some error logs


#4

I tried a new fresh install now and followed the tutorial to install the prime then run pacman -Syu and new updates arrived today about 860 mb and now its working fine but I don’t like to the nvidia to be on all the time, I will switch back to the bumblebee


#5

can someone help me why nvidia x server settings not detecting my display?


#6

why not try optimus-manager
https://wiki.manjaro.org/index.php?title=Optimus_Manager


#7

@Librewish for which one bumblebee or Prime?


#8

it is an alternative to prime


#9

Thank you
ok I will do fresh install then install Prime by this tutorial [HowTo] Set up PRIME with NVIDIA proprietary driver
then run Pacman -Syu, then run this optimus-manager,
@Librewish But do I have to remove Nvidia x server settings?


#10

no need to setup prime if you use optimus-manager


#11

Ok thank you I will try this now and get back here


#12

IMPORTANT : make sure you do not have any configuration file conflicting with the ones autogenerated by optimus-manager. In particular, remove everything related to displays or GPUs in /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/ and also in /etc/X11/mhwd.d/. Avoid running nvidia-xconfig or using the Save to X Configuration file in the Nvidia control panel. If you need to apply specific options to your Xorg config, see the Optimus_Manager#Configuration.

If you have bumblebee installed on your system, uninstall it or at least make sure the bumblebeed service is disabled. Finally, make sure the bbswitch module is not loaded at boot time (check /etc/modules-load.d/).


#13

Ok thank you, I will do this with fresh install then straight to optimus-manager I will make sure to remove those files.


#14

this is what I got how to fix this


#15

explaining what youve done to arrive at this issue would help. i saw that you were going to try and do a fresh install and then try optimus-manager, did you do this? if so at what point did :point_up: happen?
more description=more helpful answers


#16

ok thanks, first of all my bios is set to UEFI and secure boot is disabled, after fresh install I booted into the system with nouveau.modeset=0 pressed f10 , then installed yaourt then used pamac and searched for optimus-manager (it depended on bbswitch and asked to choose betwenn linux3xx linux4xx and I choose linux419 since my the system runs kernel version 419 I learned this from about system) , i installed it, then enbaled optimus service and started optimus service then per optimus manager instructions then I used hardware configuration to install invidia-video then reboot and greeted with the black screen above.
I set the default gpu to intel with optimus manager


#17

if your not able to get to a graphical desktop on your current install, you can use manjaro-chroot that comes with the live installer.
boot the live installer like you would if you were installing, connect to network and follow instruction in the manjaro wiki on how to manjaro-chroot in so you can provide information thats needed to be able to assist you.
this will help you with what info to provide:


#18

Well. I think it’s at least fair to let @Librewish to help troubleshoot this, since he hasbeen running optimus-manager for some time (and continously suggests that to everyone!.. :rofl:)


#19

oh, i dont have any idea how optimus-manager even works, im happy in the land of PRIME but i figured at the very least a graphical environment that he would be able to work from and provide needed outputs would be helpful to both himself and anyone thats helping


#20

I couldn’t get it to work , I reinstalled from scratch again , I will use intel gpu for now thank you guys .